aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/keyinteraction/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/keyinteraction/CMakeLists.txt')
-rw-r--r--examples/quick/keyinteraction/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/quick/keyinteraction/CMakeLists.txt b/examples/quick/keyinteraction/CMakeLists.txt
index 87f9352c61..96a47b0e67 100644
--- a/examples/quick/keyinteraction/CMakeLists.txt
+++ b/examples/quick/keyinteraction/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(keyinteraction LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/keyinteraction")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
qt_add_executable(keyinteractionexample WIN32 MACOSX_BUNDLE
main.cpp
)