aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/layouts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/layouts/CMakeLists.txt')
-rw-r--r--examples/quick/layouts/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/quick/layouts/CMakeLists.txt b/examples/quick/layouts/CMakeLists.txt
index 770eb82953..e1aafcf08b 100644
--- a/examples/quick/layouts/CMakeLists.txt
+++ b/examples/quick/layouts/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(layouts LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/layouts")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
qt_add_executable(layoutsexample
WIN32
MACOSX_BUNDLE
@@ -28,7 +28,7 @@ qt_add_qml_module(layoutsexample
"layouts.qml"
)
-target_link_libraries(layoutsexample PUBLIC
+target_link_libraries(layoutsexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml