aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/localstorage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/localstorage/CMakeLists.txt')
-rw-r--r--examples/quick/localstorage/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/quick/localstorage/CMakeLists.txt b/examples/quick/localstorage/CMakeLists.txt
index 934be8bf7b..0a6a9ebe51 100644
--- a/examples/quick/localstorage/CMakeLists.txt
+++ b/examples/quick/localstorage/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(localstorage LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/localstorage")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
qt_add_executable(localstorageexample
WIN32
MACOSX_BUNDLE
@@ -32,7 +32,7 @@ qt_add_qml_module(localstorageexample
"localstorage.qml"
)
-target_link_libraries(localstorageexample PUBLIC
+target_link_libraries(localstorageexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml