aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/particles/itemparticle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/particles/itemparticle/CMakeLists.txt')
-rw-r--r--examples/quick/particles/itemparticle/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/quick/particles/itemparticle/CMakeLists.txt b/examples/quick/particles/itemparticle/CMakeLists.txt
index 4f745ae641..03093e85f2 100644
--- a/examples/quick/particles/itemparticle/CMakeLists.txt
+++ b/examples/quick/particles/itemparticle/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(itemparticle LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,13 +12,15 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/particles/itemparticle")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
add_subdirectory("../../shared" "shared")
qt_add_executable(itemparticleexample WIN32 MACOSX_BUNDLE
main.cpp
)
-target_link_libraries(itemparticleexample PUBLIC
+target_link_libraries(itemparticleexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml