aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/positioners/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/positioners/CMakeLists.txt')
-rw-r--r--examples/quick/positioners/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/quick/positioners/CMakeLists.txt b/examples/quick/positioners/CMakeLists.txt
index f0c8765120..bda770a2af 100644
--- a/examples/quick/positioners/CMakeLists.txt
+++ b/examples/quick/positioners/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(positioners LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/positioners")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
add_subdirectory("../shared" "shared")
qt_add_executable(positionersexample
@@ -32,7 +32,7 @@ qt_add_qml_module(positionersexample
"positioners.qml"
)
-target_link_libraries(positionersexample PUBLIC
+target_link_libraries(positionersexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml