summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-27 16:39:30 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-27 20:09:44 +0200
commitd49f744968a237b751f0e520f8a9fff59dc283f5 (patch)
tree0db8774179a769b8c77e00f831bfcdc848fee8d8 /CMakeLists.txt
parent72521cc8e9d73514f5b65036965824919462db83 (diff)
CMake: Skip building QtNetworkAuth if QT_FEATURE_http is OFF
When configuring Qt with the http feature disabled (which happens when the thread feature is disabled e.g. when targeting WebAssembly) NetworkAuth compiled some files, but the static library was unusable. In shared builds the library failed to link at all. Skip the module if http feature is disabled. This shouldn't break our CI test phase when the repo isn't built because all such configs we have in the CI are static builds (wasm) marked with DisableTests and thus no test phase is created. Task-number: QTBUG-93243 Change-Id: I3831f4722c1dcf854cabe3d49cd81668dac0a0a4 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a067363..5433806 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,4 +22,9 @@ if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
return()
endif()
+
+if(NOT QT_FEATURE_http)
+ message(NOTICE "Skipping the build as the condition \"QT_FEATURE_http\" is not met.")
+ return()
+endif()
qt_build_repo()