summaryrefslogtreecommitdiffstats
path: root/Tools/DumpRenderTree/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/DumpRenderTree/CMakeLists.txt')
-rw-r--r--Tools/DumpRenderTree/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tools/DumpRenderTree/CMakeLists.txt b/Tools/DumpRenderTree/CMakeLists.txt
index db6ef4304..4a726ccaf 100644
--- a/Tools/DumpRenderTree/CMakeLists.txt
+++ b/Tools/DumpRenderTree/CMakeLists.txt
@@ -1,3 +1,5 @@
+QTWEBKIT_SKIP_AUTOMOC(DumpRenderTree)
+
set(DumpRenderTree_SOURCES
AccessibilityController.cpp
AccessibilityTextMarker.cpp
@@ -130,4 +132,7 @@ endif ()
if (${PORT} STREQUAL "Qt")
set_target_properties(DumpRenderTree PROPERTIES AUTOMOC ON)
+ if (ENABLE_NETSCAPE_PLUGIN_API)
+ target_compile_definitions(TestNetscapePlugin PRIVATE QT_NO_VERSION_TAGGING)
+ endif ()
endif ()