summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-01-13 13:59:06 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-01-16 12:47:40 +0000
commit9a77e6e38d96441eb1f14132b87a16708b465cbc (patch)
treeed7db597bd161d7a0cd6e2d5dc2323abff7b2f2b
parentf8bdee71ed74c664c08e459d4cb40984db5faa57 (diff)
kernel: remove kernel fixes
Fixed in uptream layer. Change-Id: Ia27579bce3c9001cbee2b35e7a2708ac4aeb4c85 Reviewed-by: Ari Parkkila <ari.parkkila@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-kernel/linux/linux-ti-staging/0001-Fix-API-break-in-init_disassemble_info.patch47
-rw-r--r--recipes-kernel/linux/linux-ti-staging_5.10.%.bbappend34
2 files changed, 0 insertions, 81 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging/0001-Fix-API-break-in-init_disassemble_info.patch b/recipes-kernel/linux/linux-ti-staging/0001-Fix-API-break-in-init_disassemble_info.patch
deleted file mode 100644
index 3d5b416..0000000
--- a/recipes-kernel/linux/linux-ti-staging/0001-Fix-API-break-in-init_disassemble_info.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From cd42b475399c84767d2cc2940ce7964c07a2bac8 Mon Sep 17 00:00:00 2001
-From: Ari Parkkila <ari.parkkila@qt.io>
-Date: Thu, 20 Oct 2022 08:37:47 +0300
-Subject: [PATCH] Fix API break in init_disassemble_info
-
-API break due to init_disassemble_info() got an extra parameter,
-see http://trofi.github.io/posts/254-binutils-2.39.html
----
- tools/perf/util/annotate.c | 15 ++++++++++++++-
- 1 file changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/tools/perf/util/annotate.c b/tools/perf/util/annotate.c
-index e42bf572358c..779e9d5fdb16 100644
---- a/tools/perf/util/annotate.c
-+++ b/tools/perf/util/annotate.c
-@@ -1708,6 +1708,18 @@ static int dso__disassemble_filename(struct dso *dso, char *filename, size_t fil
- #include <bfd.h>
- #include <dis-asm.h>
-
-+static int fprintf_styled(void *, enum disassembler_style, const char* fmt, ...)
-+{
-+ va_list args;
-+ int r;
-+
-+ va_start(args, fmt);
-+ r = vprintf(fmt, args);
-+ va_end(args);
-+
-+ return r;
-+}
-+
- static int symbol__disassemble_bpf(struct symbol *sym,
- struct annotate_args *args)
- {
-@@ -1750,7 +1762,8 @@ static int symbol__disassemble_bpf(struct symbol *sym,
- goto out;
- }
- init_disassemble_info(&info, s,
-- (fprintf_ftype) fprintf);
-+ (fprintf_ftype) fprintf,
-+ fprintf_styled);
-
- info.arch = bfd_get_arch(bfdf);
- info.mach = bfd_get_mach(bfdf);
---
-2.25.1
-
diff --git a/recipes-kernel/linux/linux-ti-staging_5.10.%.bbappend b/recipes-kernel/linux/linux-ti-staging_5.10.%.bbappend
deleted file mode 100644
index baa1bc3..0000000
--- a/recipes-kernel/linux/linux-ti-staging_5.10.%.bbappend
+++ /dev/null
@@ -1,34 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2022 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SRC_URI:append = "\
- file://0001-Fix-API-break-in-init_disassemble_info.patch \
-"