aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-04-27 12:02:27 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-04-27 10:51:32 +0000
commitd54122272b36404e176683988d6e4d6db635375c (patch)
tree681f7d8cb0ba23d57079176deae703d625024a2c
parent4be5ca22ed0596dc06e0cd598c103da825f50edd (diff)
Add product name and Qt version to image confv2.0.1_QtAS
Flashing wizard now support product and qt settings items. Use also correct product name for automotive images. Task-number: AUTOSUITE-286 Change-Id: Iffba7c004b69d410d7b76434b1cccff6836ff23d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--classes/deploy-conf.bbclass8
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb2
2 files changed, 7 insertions, 3 deletions
diff --git a/classes/deploy-conf.bbclass b/classes/deploy-conf.bbclass
index 228b1e20..22c6ef7d 100644
--- a/classes/deploy-conf.bbclass
+++ b/classes/deploy-conf.bbclass
@@ -29,15 +29,19 @@
inherit image_types
+IMAGE_DEPENDS_conf = "qtbase-native"
+
DEPLOY_CONF_NAME ?= "${MACHINE}"
DEPLOY_CONF_TYPE ?= "Boot2Qt"
IMAGE_CMD_conf() {
+ QT_VERSION=$(qmake -query QT_VERSION)
cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF
-[${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}]
+[${DEPLOY_CONF_NAME}]
platform=${MACHINE}
+product=${DEPLOY_CONF_TYPE}
+qt=Qt $QT_VERSION
os=linux
-board=
imagefile=${IMAGE_LINK_NAME}.img
asroot=true
EOF
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 67819d76..7c6c2dec 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
PR = "r0"
-DEPLOY_CONF_TYPE = "Automotive"
+DEPLOY_CONF_TYPE = "Qt Automotive Suite 2.0.1"
IMAGE_FEATURES += "\
package-management \