aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-04 16:15:02 +0300
commit51a55da41a8cdd4f637a6c6cd44e1ac2ba74ae32 (patch)
treeb57ff35bf91a67fc0d6c3eb7831ed82f5f575c47 /classes
parent61d552148d797866ed33a9cd5e56477873cf801d (diff)
parente3ef984ac6f5926d7a910eff33bafeb5da6c2ff0 (diff)
Merge remote-tracking branch 'origin/fido' into dev
* origin/fido: automotive: update src uris after repos were opened colibri-vf: change partition alignment to 1M Make ABI selection more robust in configure-qtcreator.sh Conflicts: recipes-qt/automotive/neptune-ui_git.bb recipes-qt/automotive/qtapplicationmanager_git.bb recipes-qt/automotive/qtivi_git.bb Change-Id: I86763619f24b40e9ac62a8c1ae84acf4ffeb4be7
Diffstat (limited to 'classes')
-rw-r--r--classes/abi-arch.bbclass41
-rw-r--r--classes/populate_b2qt_qt5_sdk.bbclass4
2 files changed, 43 insertions, 2 deletions
diff --git a/classes/abi-arch.bbclass b/classes/abi-arch.bbclass
new file mode 100644
index 00000000..826fed49
--- /dev/null
+++ b/classes/abi-arch.bbclass
@@ -0,0 +1,41 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+# map target architecture to abi architectures used by Qt Creator
+valid_archs = "arm x86 itanium mips ppc sh"
+
+def map_abi_arch(a, d):
+ import re
+
+ valid_archs = d.getVar('valid_archs', True).split()
+
+ if re.match('i.86$', a): return 'x86'
+ elif re.match('x86.64$', a): return 'x86'
+ elif re.match('armeb$', a): return 'arm'
+ elif re.match('aarch64', a): return 'arm'
+ elif re.match('mips(el|64|64el)$', a): return 'mips'
+ elif re.match('p(pc|owerpc)(|64)', a): return 'ppc'
+ elif re.match('sh(3|4)$', a): return 'sh'
+ elif a in valid_archs: return a
+ else:
+ bb.error("cannot map '%s' to a abi architecture" % a)
+
+ABI = "${@map_abi_arch(d.getVar('TARGET_ARCH', True), d)}"
diff --git a/classes/populate_b2qt_qt5_sdk.bbclass b/classes/populate_b2qt_qt5_sdk.bbclass
index d6b2b108..ae886857 100644
--- a/classes/populate_b2qt_qt5_sdk.bbclass
+++ b/classes/populate_b2qt_qt5_sdk.bbclass
@@ -19,7 +19,7 @@
##
##############################################################################
-inherit populate_b2qt_sdk populate_sdk_qt5_base
+inherit populate_b2qt_sdk populate_sdk_qt5_base abi-arch siteinfo
SDK_MKSPEC_DIR = "${SDK_OUTPUT}${SDKTARGETSYSROOT}${libdir}/${QT_DIR_NAME}/mkspecs"
SDK_MKSPEC = "devices/linux-oe-generic-g++"
@@ -65,7 +65,7 @@ create_qtcreator_configure_script () {
# add qtcreator configuration script
install -m 0755 ${B2QTBASE}/scripts/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH}
sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
- sed -i -e '/^ABI=/c\ABI="${ARCH}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
+ sed -i -e '/^ABI=/c\ABI="${ABI}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
}
create_qtcreator_configure_script_mingw32 () {