aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-18 10:14:32 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-18 10:15:24 +0300
commitabd29cce5e3cc3b0d0d2cf023bb9d327ef96f548 (patch)
treef58615ff2ceb23fe22d15901e977772d865ebf80 /classes
parent64d0d088725b7ad70080068c3eb9f5dccec9bd32 (diff)
parent293bb2b4195281d7b4a56f16c77bdf16831334e4 (diff)
Merge remote-tracking branch 'origin/fido' into dev
* origin/fido: Move usage of internal mirrors into a bbclass Use --internal arg to fetch playground repos qtquickcompiler: update revision to work with Qt 5.6.1 qt5: update submodules gcc: patch already applied on oe layer Update revisions for poky and openembedded Fix meta-environment to work without changes in local.conf Disabled SSTATE_MIRRORS and PRE_MIRRORS. setup-environment: prevent basename argument being parsed as option. Do not pull internal repos when initializing for all devices Conflicts: conf/local.conf.sample recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qt3d_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtcanvas3d_git.bbappend recipes-qt/qt5/qtconnectivity_git.bbappend recipes-qt/qt5/qtdeclarative_git.bbappend recipes-qt/qt5/qtgraphicaleffects_git.bbappend recipes-qt/qt5/qtimageformats_git.bbappend recipes-qt/qt5/qtlocation_git.bbappend recipes-qt/qt5/qtmultimedia_git.bbappend recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtquickcontrols_git.bbappend recipes-qt/qt5/qtsensors_git.bbappend recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bbappend recipes-qt/qt5/qtsvg_git.bbappend recipes-qt/qt5/qttools_git.bbappend recipes-qt/qt5/qttranslations_git.bbappend recipes-qt/qt5/qtwayland-native_git.bbappend recipes-qt/qt5/qtwayland_git.bbappend recipes-qt/qt5/qtwebchannel_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend recipes-qt/qt5/qtwebsockets_git.bbappend recipes-qt/qt5/qtxmlpatterns_git.bbappend scripts/manifest.xml scripts/manifest_jethro.xml Change-Id: I17c4dd6890dc4475171133cede4dc7e6217222d6
Diffstat (limited to 'classes')
-rw-r--r--classes/internal-build.bbclass46
1 files changed, 46 insertions, 0 deletions
diff --git a/classes/internal-build.bbclass b/classes/internal-build.bbclass
new file mode 100644
index 00000000..0fb28e55
--- /dev/null
+++ b/classes/internal-build.bbclass
@@ -0,0 +1,46 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+python enable_internal_build () {
+ import socket
+ try:
+ socket.gethostbyname('yocto-cache.ci.local')
+ except:
+ return
+
+ e.data.setVar('SSTATE_MIRRORS', "file://.* http://yocto-cache.ci.local/sstate-caches/${DISTRO_CODENAME}/PATH")
+ e.data.setVar('PREMIRRORS', "\
+ ftp://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ http://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ https://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ bzr://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ cvs://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ git://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ gitsm://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ hg://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ osc://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ p4://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ svn://.*/.* http://yocto-cache.ci.local/sources/ \n \
+ ")
+}
+
+addhandler enable_internal_build
+enable_internal_build[eventmask] = "bb.event.ConfigParsed"