aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-11 11:34:45 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-12 10:14:50 +0000
commit1908d95fae1f57e451068b54927cbfeb7079c253 (patch)
tree47bd9b14ad845dcb8a90187267a2881046b37876 /meta-fsl-extras
parente8a3c3509903716ebacc9e73927f586b94994574 (diff)
u-boot-boundary: Add support for KOE tx31d200vm0baa display
Change-Id: I765336429009433cd361dd1bacae9c743ed58fd5 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch90
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend25
2 files changed, 115 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
new file mode 100644
index 00000000..0343f062
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
@@ -0,0 +1,90 @@
+From 554d219b3485402c6992abc0aa32c74e8f251876 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@theqtcompany.com>
+Date: Thu, 11 Feb 2016 10:17:51 +0200
+Subject: [PATCH] Add support for KOE tx31d200vm0baa display
+
+Used for the cluster demo
+---
+ arch/arm/include/asm/imx-common/fbpanel.h | 27 +++++++++++++++++++++++++++
+ board/boundary/nitrogen6_max/nitrogen6_max.c | 1 +
+ board/boundary/nitrogen6sx/nitrogen6sx.c | 1 +
+ board/boundary/nitrogen6x/nitrogen6x.c | 1 +
+ 4 files changed, 30 insertions(+)
+
+diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h
+index b6f7af4..b8acdae 100644
+--- a/arch/arm/include/asm/imx-common/fbpanel.h
++++ b/arch/arm/include/asm/imx-common/fbpanel.h
+@@ -39,6 +39,33 @@ void fbp_enable_fb(struct display_info_t const *di, int enable);
+ int fbp_detect_i2c(struct display_info_t const *di);
+ void fbp_setup_display(const struct display_info_t *displays, int cnt);
+
++/* tx31d200vm0baa == koe */
++#define IMX_VD_KOE(_mode, _detect, _bus) \
++{\
++ .bus = _bus,\
++ .addr = 0,\
++ .pixfmt = IPU_PIX_FMT_RGB666,\
++ .detect = NULL,\
++ .enable = fbp_enable_fb,\
++ .fbtype = FB_##_mode,\
++ .fbflags = 0,\
++ .mode = {\
++ .name = "koe",\
++ .refresh = 60,\
++ .xres = 1280,\
++ .yres = 480,\
++ .pixclock = 1000000000000ULL/((1280+80+48+32)*(480+15+2+6)*60),\
++ .left_margin = 80,\
++ .right_margin = 48,\
++ .upper_margin = 15,\
++ .lower_margin = 2,\
++ .hsync_len = 32,\
++ .vsync_len = 6,\
++ .sync = FB_SYNC_EXT,\
++ .vmode = FB_VMODE_NONINTERLACED\
++ }\
++}
++
+ /* hdmi settings */
+ #define IMX_VD50_1280_720M_60(_mode, _detect, _bus) \
+ {\
+diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
+index 337e9b5..ba29aee 100644
+--- a/board/boundary/nitrogen6_max/nitrogen6_max.c
++++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
+@@ -568,6 +568,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
+ }
+
+ static const struct display_info_t displays[] = {
++ IMX_VD_KOE(LVDS, 0, 2),
+ /* hdmi */
+ IMX_VD50_1280_720M_60(HDMI, 1, 1),
+ IMX_VD50_1920_1080M_60(HDMI, 0, 1),
+diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
+index cdabcd8..de6582e 100644
+--- a/board/boundary/nitrogen6sx/nitrogen6sx.c
++++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
+@@ -685,6 +685,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
+
+
+ static const struct display_info_t displays[] = {
++ IMX_VD_KOE(LVDS, 0, 2),
+ /* hdmi/lcd */
+ _IMX_VD_1280_720M_60(LCD, 1, 2, 50, 0),
+ _IMX_VD_1920_1080M_60(LCD, 0, 2, 50, 0),
+diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
+index 21d6cd7..b24f2f6 100644
+--- a/board/boundary/nitrogen6x/nitrogen6x.c
++++ b/board/boundary/nitrogen6x/nitrogen6x.c
+@@ -525,6 +525,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
+ }
+
+ static const struct display_info_t displays[] = {
++ IMX_VD_KOE(LVDS, 0, 2),
+ /* hdmi */
+ IMX_VD50_1280_720M_60(HDMI, 1, 1),
+ IMX_VD50_1920_1080M_60(HDMI, 0, 1),
+--
+1.9.1
+
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
new file mode 100644
index 00000000..7487f7d8
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
@@ -0,0 +1,25 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI += " \
+ file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
+ "