aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2016-11-21 12:28:18 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-04-21 06:46:19 +0000
commit8afceb4e6a6c40f471f903cdf7f12e136e9ff971 (patch)
treeab0a9f273179b351060684691ca3e1e0c44f622b /meta-fsl-extras
parent70be5526bd98a97c60301c83c1a88e7bb6b19360 (diff)
Add support for i.MX7S WaRP
Change-Id: Ib2c82ccf8d7648bb303e0fc949e3c1aef5b09195 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
new file mode 100644
index 00000000..82604d4a
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
@@ -0,0 +1,34 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_configure_prepend() {
+ echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+}