aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-04-13 14:57:27 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-04-24 06:57:05 +0000
commitc91018095897ac9b4dea998700809a5555f9b1dc (patch)
treea6b89f433aab82eae023be6399f5de40d2489902 /meta-fsl-extras
parent598139f2e742ccac9d0a31030209e14a73317764 (diff)
fsl: update freescale meta layers & related .bbappend entries
* Update meta-freescale & meta-freescale-3rdparty layers to the latest SHA1s in morty branches * Update related meta-boot2qt/meta-fsl-extras .bbappend entries by removing duplicate/obsolete entries * Update CMA-reserved-size patch for nitrogen6x * Remove Add-recovery-support patch Change-Id: Ifa1063d7b8bb4f76eea0c9c735f483136d2cd8bb Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend2
-rw-r--r--meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend5
-rw-r--r--meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend4
-rw-r--r--meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend1
-rw-r--r--meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend4
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch37
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch23
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend2
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch27
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend1
10 files changed, 25 insertions, 81 deletions
diff --git a/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend
index 4c472db7..068b9fa9 100644
--- a/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend
+++ b/meta-fsl-extras/recipes/broadcom-nvram-config/bcm4330-nvram-config.bbappend
@@ -29,4 +29,4 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}:"
-COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|wandboard-dual|wandboard-quad)"
+COMPATIBLE_MACHINE = "(cubox-i|nitrogen6x|nitrogen6x-lite|wandboard|imx6sl-warp)"
diff --git a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
index c4e01582..9a50c92b 100644
--- a/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-fslc-imx_4.%.bbappend
@@ -35,12 +35,7 @@ do_preconfigure_prepend() {
echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
# Enable USB serial support
- echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
}
diff --git a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
index c4e01582..208ec74b 100644
--- a/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-imx_4.%.bbappend
@@ -35,11 +35,7 @@ do_preconfigure_prepend() {
echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
# Enable USB serial support
- echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend
index f8fac0d8..58c64dec 100644
--- a/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-toradex_3.14.%.bbappend
@@ -33,5 +33,4 @@ RDEPENDS_kernel-base = ""
do_preconfigure_prepend () {
# FunctionFS for adb
echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
}
diff --git a/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend
index 58302382..431005b2 100644
--- a/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend
+++ b/meta-fsl-extras/recipes/linux/linux-toradex_4.%.bbappend
@@ -32,9 +32,5 @@ RDEPENDS_kernel-base = "kernel-image kernel-devicetree"
do_preconfigure_prepend () {
# FunctionFS for adb
echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
- echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
echo "TOUCHSCREEN_FUSION_F0710A=y" >> ${WORKDIR}/defconfig
-
- echo "CONFIG_EXTCON=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_EXTCON_USB_GPIO=y" >> ${WORKDIR}/defconfig
}
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch
deleted file mode 100644
index d1f5616c..00000000
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-Add-recovery-support.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 33a5a73cd846c0bbf6a507aa4e658c74815eb1d7 Mon Sep 17 00:00:00 2001
-From: Rainer Keller <Rainer.Keller@qt.io>
-Date: Wed, 4 May 2016 12:49:40 +0200
-Subject: [PATCH] Add recovery support
-
----
- include/configs/nitrogen6x.h | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
-index bbc613d..9c939e6 100644
---- a/include/configs/nitrogen6x.h
-+++ b/include/configs/nitrogen6x.h
-@@ -232,6 +232,11 @@
- "clearenv=if sf probe || sf probe || sf probe 1 ; then " \
- "sf erase 0xc0000 0x2000 && " \
- "echo restored environment to factory default ; fi\0" \
-+ "recovery_boot=setenv recovery true ; dtype=mmc ; setenv bootpart 3 ; " \
-+ "for disk in 0 1 ; do " \
-+ "${dtype} dev ${disk} ; " \
-+ "load ${dtype} ${disk}:${bootpart} 10008000 /6x_bootscript && source 10008000 ; " \
-+ "done\0" \
- "bootcmd=for dtype in ${bootdevs}" \
- "; do " \
- "if itest.s \"xusb\" == \"x${dtype}\" ; then " \
-@@ -245,6 +250,8 @@
- "&& source 10008000 ; " \
- "done ; " \
- "done; " \
-+ "echo Startup failed, running recovery ; " \
-+ "run recovery_boot ; " \
- "setenv stdout serial,vga ; " \
- "echo ; echo 6x_bootscript not found ; " \
- "echo ; echo serial console at 115200, 8N1 ; echo ; " \
---
-2.7.3
-
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
new file mode 100644
index 00000000..9eda1997
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
@@ -0,0 +1,23 @@
+From 59d272d9df5337bb4bd62a96fc16c8e280c49344 Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Sun, 23 Apr 2017 21:47:01 +0300
+Subject: [PATCH] set CMA reserved size to 384MB
+
+Increased from 256MB (the default) to 384MB. Without this, HW-accelerated
+video decoding cannot work for high resolution videos.
+---
+ include/configs/nitrogen6x.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
+index 646c505..ddbb4c5 100644
+--- a/include/configs/nitrogen6x.h
++++ b/include/configs/nitrogen6x.h
+@@ -28,6 +28,7 @@
+ #define CONFIG_USB_MAX_CONTROLLER_COUNT 2
+ #define CONFIG_VIDEO
+ #define BD_I2C_MASK 7
++#define BD_CMA "384M"
+
+ #if defined(CONFIG_SABRELITE)
+ #define CONFIG_ENV_IS_IN_MMC
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
index 5f0d1554..013e54b4 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary_git.bbappend
@@ -30,5 +30,5 @@
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += " \
file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
- file://0002-Add-recovery-support.patch \
+ file://0002-set-CMA-reserved-size-to-384MB.patch \
"
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch
deleted file mode 100644
index d6483403..00000000
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-set-CMA-reserved-size-to-384MB.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 3bb661da09e2a57ef452d388d69b8d01044136f1 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@theqtcompany.com>
-Date: Wed, 13 Jan 2016 09:26:33 +0200
-Subject: [PATCH] set CMA reserved size to 384MB
-
-Increased from 256MB (the default) to 384MB. Without this, HW-accelerated
-video decoding cannot work for high resolution videos.
----
- board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-index 86242b5..da4ea05 100644
---- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-+++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-@@ -92,7 +92,7 @@ if itest.s "x" == "x${cmd_xxx_present}" ; then
- echo "!!!!!!!!!!!!!!!!"
- fi
-
--setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M consoleblank=0 rootwait fixrtc"
-+setenv bootargs "${bootargs} console=${console},115200 vmalloc=400M cma=384M consoleblank=0 rootwait fixrtc"
-
-
- bpart=2
---
-1.9.1
-
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
index a01780ae..dafcf84a 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
@@ -29,6 +29,5 @@
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += " \
- file://0001-set-CMA-reserved-size-to-384MB.patch \
file://0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch \
"