aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorYoann Lopes <yoann.lopes@theqtcompany.com>2015-06-10 16:29:42 +0200
committerEirik Aavitsland <eirik.aavitsland@theqtcompany.com>2015-06-19 09:22:28 +0300
commiteb2eb7ce5d43d623d7d4ff1bd7a584feafc38fe8 (patch)
tree7e9eaacc1412343eb579dda712335725b602a525 /meta-fsl-extras
parent0cf281fdd678ea57b34bd9c7e5c48dc421d290ae (diff)
Increase CMA reserved size on nitrogen6x.
Increased from 256MB (the default) to 384MB. Without this, HW-accelerated video decoding cannot work for high resolution videos. The same might have to be done on other iMX devices. Change-Id: I202ee246d59ded0343a93b6bdf221bd69fcd22c5 Reviewed-by: Laszlo Agocs <laszlo.agocs@theqtcompany.com>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch (renamed from meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch)10
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend2
2 files changed, 7 insertions, 5 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch
index d97921c3..f42b213e 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-disable-console-cursor-blinking.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary/0001-nitrogen6x-update-bootargs.patch
@@ -1,8 +1,10 @@
From b21614109fb3cca15c4b0d296b3ab6cc1b778e3a Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@digia.com>
-Date: Fri, 10 Jan 2014 12:37:20 +0200
-Subject: [PATCH] nitrogen6x: disable console cursor blinking
+From: Yoann Lopes <yoann.lopes@theqtcompany.com>
+Date: Wed, 10 Jun 2015 16:36:10 +0100
+Subject: [PATCH] nitrogen6x: update bootargs.
+- disable console cursor blinking
+- set CMA reserved size to 384MB
---
board/boundary/nitrogen6x/6x_bootscript-yocto.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -16,7 +18,7 @@ index d933fa0..2d7c575 100644
setenv bootargs $bootargs $fbmem
-setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 rootwait"
-+setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 rootwait"
++setenv bootargs "$bootargs console=ttymxc1,115200 vmalloc=400M consoleblank=0 vt.global_cursor_default=0 cma=384M rootwait"
if itest.s x$bootpart == x ; then
bootpart=1
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
index 1a0fe522..abbc2228 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-script-boundary_git.bbappend
@@ -22,6 +22,6 @@
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += " \
- file://0001-nitrogen6x-disable-console-cursor-blinking.patch \
+ file://0001-nitrogen6x-update-bootargs.patch \
file://0002-nitrogen6x-update.patch \
"