aboutsummaryrefslogtreecommitdiffstats
path: root/meta-nvidia-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-31 08:24:30 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-02-15 08:32:05 +0000
commit505d8414e11d4da9d8fc485931f2af6fdfd5912f (patch)
tree743f22f93422748f243c125908c1eaf90af6e8f6 /meta-nvidia-extras
parentcbfd8dd6a9ff034ec1e2839c1e72ee0973163195 (diff)
Rename nvidia extra layers
Reserve meta-tegra-extras for the open source meta-tegra layer used for Jetson TX1 and TK1. Change-Id: I78b168105f306ee342671b612205d68b56016c14 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-nvidia-extras')
-rw-r--r--meta-nvidia-extras/conf/layer.conf40
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend40
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf/main.conf4
-rw-r--r--meta-nvidia-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend33
-rw-r--r--meta-nvidia-extras/recipes/firmware/tegra-firmware_1.0.bbappend35
-rw-r--r--meta-nvidia-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend30
-rw-r--r--meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend7
-rw-r--r--meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend69
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend30
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend31
-rw-r--r--meta-nvidia-extras/recipes/systemd/systemd_%.bbappend30
-rw-r--r--meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers/egl.pc12
-rw-r--r--meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend49
-rw-r--r--meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch105
-rw-r--r--meta-nvidia-extras/recipes/wayland/wayland_%.bbappend36
-rw-r--r--meta-nvidia-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch13
-rw-r--r--meta-nvidia-extras/recipes/weston/weston_%.bbappend36
17 files changed, 600 insertions, 0 deletions
diff --git a/meta-nvidia-extras/conf/layer.conf b/meta-nvidia-extras/conf/layer.conf
new file mode 100644
index 00000000..f1717acd
--- /dev/null
+++ b/meta-nvidia-extras/conf/layer.conf
@@ -0,0 +1,40 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend \
+"
+
+BBFILE_COLLECTIONS += "b2qt_nvidia"
+BBFILE_PATTERN_b2qt_nvidia := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt_nvidia = "20"
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
new file mode 100644
index 00000000..3cfe2348
--- /dev/null
+++ b/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
@@ -0,0 +1,40 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+FILES_${PN} += "etc/connman/main.conf"
+
+SRC_URI += "file://main.conf \
+ "
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/connman
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
+}
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf/main.conf b/meta-nvidia-extras/recipes/connman-conf/connman-conf/main.conf
new file mode 100644
index 00000000..a1e45b95
--- /dev/null
+++ b/meta-nvidia-extras/recipes/connman-conf/connman-conf/main.conf
@@ -0,0 +1,4 @@
+[General]
+PreferredTechnologies=ethernet,wifi,cellular
+NetworkInterfaceBlacklist=eth0
+
diff --git a/meta-nvidia-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend b/meta-nvidia-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
new file mode 100644
index 00000000..4314a205
--- /dev/null
+++ b/meta-nvidia-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
@@ -0,0 +1,33 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PROVIDES = "virtual/egl virtual/libgles2"
+RPROVIDES_${PN} = "libegl libegl-dev libgles2 libgles2-dev"
+RCONFLICTS_${PN} = "libegl-mesa libegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
+RREPLACES_${PN} = "libegl-mesa lbegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
diff --git a/meta-nvidia-extras/recipes/firmware/tegra-firmware_1.0.bbappend b/meta-nvidia-extras/recipes/firmware/tegra-firmware_1.0.bbappend
new file mode 100644
index 00000000..d3e2337a
--- /dev/null
+++ b/meta-nvidia-extras/recipes/firmware/tegra-firmware_1.0.bbappend
@@ -0,0 +1,35 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# WARNING: FILESEXTRAPATHS-variable, must always use _prepend (or _append)
+FILESEXTRAPATHS_tegra-x1_prepend = "__default:"
+FILESEXTRAPATHS_tegra-t18x_prepend = "__default:"
+
+# ERROR: QA Issue: Files/directories were installed but not shipped in any package
+FILES_${PN}-gk20a = "${FILES__${PN}-gk20a}"
diff --git a/meta-nvidia-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend b/meta-nvidia-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
new file mode 100644
index 00000000..df91dfe9
--- /dev/null
+++ b/meta-nvidia-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend b/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend
new file mode 100644
index 00000000..f2bdba13
--- /dev/null
+++ b/meta-nvidia-extras/recipes/linux-libc-headers/linux-libc-headers_4.%.bbappend
@@ -0,0 +1,7 @@
+# Use our kernel instead of yocto which defaults to mainline 3.18
+SRC_URI = "file://${KERN_DIR}/linux.tar.bz2"
+PV = "3.18"
+
+# Extracting linux.tar.bz2 creates directories
+# <top>/vibrante-oss-src/kernel
+S = "${WORKDIR}/vibrante-oss-src/kernel"
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
new file mode 100644
index 00000000..70ee5154
--- /dev/null
+++ b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
@@ -0,0 +1,69 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_unpack_append() {
+ rm -rf ${STAGING_KERNEL_DIR}
+ ln -s ${S} ${STAGING_KERNEL_DIR}
+}
+
+do_kernel_defconfig_prepend () {
+}
+
+do_compile_prepend () {
+ # cross_compile_exports
+ export ARCH=${KERNEL_ARCH}
+ export CROSS_COMPILE=${CROSS_COMPILE}
+
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
+ echo "CONFIG_USB_ACM=m" >> ${B}/.config
+
+ make olddefconfig
+}
+
+do_install () {
+ kernel_do_install
+
+ s=$(readlink -m "${S}")
+ kernsrc="${STAGING_KERNEL_DIR}"
+
+ if [ "${s}" != "${kernsrc}" ]; then
+ mkdir -p "${kernsrc}"
+ rm -rf "${kernsrc}"
+ mv "${S}" "${STAGING_KERNEL_DIR}"
+ ln -sf "${kernsrc}" "${s}"
+ fi
+}
+
+do_deploy() {
+ kernel_do_deploy
+}
+
+do_compile () {
+ kernel_do_compile
+}
diff --git a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 00000000..8770c65d
--- /dev/null
+++ b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG += "kms"
diff --git a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
new file mode 100644
index 00000000..94178dbd
--- /dev/null
+++ b/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,31 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
+COMPATIBLE_MACHINE_aarch64 = "(.*)"
diff --git a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend b/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
new file mode 100644
index 00000000..53ea1e49
--- /dev/null
+++ b/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+SRC_URI_remove = "file://0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch"
diff --git a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers/egl.pc b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
new file mode 100644
index 00000000..da1f5f7d
--- /dev/null
+++ b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
@@ -0,0 +1,12 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=/usr/lib
+includedir=/usr/include
+
+Name: egl
+Description: Mesa EGL library
+Requires.private: libdrm >= 2.4.24
+Version: 9.1.6
+Libs: -L${libdir} -lEGL
+Libs.private: -lm -lpthread -ldl
+Cflags: -I${includedir}
diff --git a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
new file mode 100644
index 00000000..2cc22df1
--- /dev/null
+++ b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
@@ -0,0 +1,49 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://egl.pc"
+FILES_${PN} += "egl.pc"
+
+GRAPHICS_PACKAGES = " \
+ virtual/libgles2 \
+ virtual/libegl \
+ virtual/egl \
+ virtual/libgl \
+ virtual/libgles1 \
+ virtual/mesa \
+ libgbm \
+ libgbm-dev \
+ "
+
+do_install_append_tegra-t18x() {
+ install -d ${D}/usr/lib/pkgconfig
+ install -m 0775 ${WORKDIR}/egl.pc ${D}/${libdir}/pkgconfig
+}
diff --git a/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch b/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch
new file mode 100644
index 00000000..5e0e6bf1
--- /dev/null
+++ b/meta-nvidia-extras/recipes/wayland/wayland/always-build-scanner.patch
@@ -0,0 +1,105 @@
+build: always build wayland-scanner
+
+The previous idiom for building a cross-compiled Wayland is to build once for
+the build host (with --enable-scanner --disable-libraries) to get a
+wayland-scanner binary that can then be used in a cross-compile (with
+--disable-scanner). The problem with this is that the cross wayland is missing
+a wayland-scanner binary, which means you then can't do any Wayland development
+on the target.
+
+Instead, always build wayland-scanner for the target and change
+--enable/disable-scanner to --with/without-host-scanner. Normal builds use the
+default of --without-host-scanner and run the wayland-scanner it just built, and
+cross-compiled builds pass --with-host-scanner to use a previously built host
+scanner but still get a wayland-scanner to install.
+
+(a theoretically neater solution would be to build two scanners if required (one
+to run and one to install), but automake makes this overly complicated)
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+Upstream-Status: Submitted
+
+diff --git a/Makefile.am b/Makefile.am
+index c19494f..c2d929b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -64,16 +64,17 @@ nodist_libwayland_client_la_SOURCES = \
+
+ pkgconfig_DATA += src/wayland-client.pc src/wayland-server.pc
+
+-if ENABLE_SCANNER
+-wayland_scanner = $(top_builddir)/wayland-scanner
+ bin_PROGRAMS = wayland-scanner
+ wayland_scanner_SOURCES = src/scanner.c
+ wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS)
+ wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la
+-$(BUILT_SOURCES) : wayland-scanner
+ pkgconfig_DATA += src/wayland-scanner.pc
+-else
++
++if HOST_SCANNER
+ wayland_scanner = wayland-scanner
++else
++$(BUILT_SOURCES) : wayland-scanner
++wayland_scanner = $(top_builddir)/wayland-scanner
+ endif
+
+ protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml
+diff --git a/configure.ac b/configure.ac
+index c2a804e..de0b02f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,11 +65,11 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+ [[#include <time.h>]])
+ AC_CHECK_HEADERS([execinfo.h])
+
+-AC_ARG_ENABLE([scanner],
+- [AC_HELP_STRING([--disable-scanner],
+- [Disable compilation of wayland-scanner])],
+- [],
+- [enable_scanner=yes])
++AC_ARG_WITH([host-scanner],
++ [AC_HELP_STRING([--with-host-scanner],
++ [Use a host wayland-scanner])],
++ [],
++ [with_host_scanner=no])
+
+ AC_ARG_ENABLE([documentation],
+ [AC_HELP_STRING([--disable-documentation],
+@@ -77,25 +77,23 @@ AC_ARG_ENABLE([documentation],
+ [],
+ [enable_documentation=yes])
+
+-AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes)
++AM_CONDITIONAL(HOST_SCANNER, test "x$with_host_scanner" = xyes)
+
+ AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here],
+ [ ICONDIR=$withval],
+ [ ICONDIR=${datadir}/icons])
+ AC_SUBST([ICONDIR])
+
+-if test "x$enable_scanner" = "xyes"; then
+- PKG_CHECK_MODULES(EXPAT, [expat], [],
+- [AC_CHECK_HEADERS(expat.h, [],
+- [AC_MSG_ERROR([Can't find expat.h. Please install expat.])])
+- SAVE_LIBS="$LIBS"
+- AC_SEARCH_LIBS(XML_ParserCreate, expat, [],
+- [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
+- EXPAT_LIBS="$LIBS"
+- LIBS="$SAVE_LIBS"
+- AC_SUBST(EXPAT_LIBS)
+- ])
+-fi
++PKG_CHECK_MODULES(EXPAT, [expat], [],
++ [AC_CHECK_HEADERS(expat.h, [],
++ [AC_MSG_ERROR([Can't find expat.h. Please install expat.])])
++ SAVE_LIBS="$LIBS"
++ AC_SEARCH_LIBS(XML_ParserCreate, expat, [],
++ [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
++ EXPAT_LIBS="$LIBS"
++ LIBS="$SAVE_LIBS"
++ AC_SUBST(EXPAT_LIBS)
++ ])
+
+ AC_PATH_PROG(XSLTPROC, xsltproc)
+ AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
diff --git a/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend b/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend
new file mode 100644
index 00000000..463d5a1f
--- /dev/null
+++ b/meta-nvidia-extras/recipes/wayland/wayland_%.bbappend
@@ -0,0 +1,36 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_append := ":${NVLAYER_DIR}/packages:${LNX_TOPDIR}/${PN}:${THISDIR}/${PN}"
+
+SRC_URI_remove = "file://${NVLAYER_DIR}/packages/wayland-1.8.1-src.tar.gz"
+SRC_URI = "\
+ file://wayland-1.8.1-src.tar.gz \
+ file://always-build-scanner.patch \
+ "
diff --git a/meta-nvidia-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch b/meta-nvidia-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch
new file mode 100644
index 00000000..062da5ce
--- /dev/null
+++ b/meta-nvidia-extras/recipes/weston/weston/disable-wayland-scanner-pkg-check.patch
@@ -0,0 +1,13 @@
+Index: weston-1.5.0/configure.ac
+===================================================================
+--- weston-1.5.0.orig/configure.ac
++++ weston-1.5.0/configure.ac
+@@ -503,7 +503,7 @@ if test x$wayland_scanner = x; then
+ AC_MSG_ERROR([wayland-scanner is needed to compile weston])
+ fi
+
+-PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
++#PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
+
+ AC_CONFIG_FILES([Makefile src/version.h src/weston.pc])
+
diff --git a/meta-nvidia-extras/recipes/weston/weston_%.bbappend b/meta-nvidia-extras/recipes/weston/weston_%.bbappend
new file mode 100644
index 00000000..cfc286fd
--- /dev/null
+++ b/meta-nvidia-extras/recipes/weston/weston_%.bbappend
@@ -0,0 +1,36 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+S = "${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston"
+
+do_install_prepend() {
+ mkdir -p ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools
+ cp ${WORKDIR}/${LNX_TOPDIR}/samples/wayland/weston/tools/weston.ini ${WORKDIR}/${LNX_TOPDIR}/samples/weston/tools/weston.ini
+}