aboutsummaryrefslogtreecommitdiffstats
path: root/meta-nvidia-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2016-04-13 15:47:51 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-05-05 08:16:14 +0000
commit86ce53afdeb5fbf863100231b83521bf34375930 (patch)
tree2926e8631c2197bdcb10a35c0d31cf5c4e078945 /meta-nvidia-extras
parent5800a3bfe48a2092ac3b8cf250f04840a6397f3f (diff)
Fix to NVidia's tegra configurations.
Changed both nvidia-logan and tegra-t18x to use the same metalayer from the Vibrante 4.0 SDK. Kernel sources and libraries are stored into the internal CI repository. These definitions can be overridden by SDK folder using following environment variables: export KERN_DIR=~/Vibrante4.0_RC1/vibrante-t186ref-linux_src/kernel export PLATFORM_TOPDIR=~/Vibrante4.0_RC1/vibrante-t186ref-linux export TOOLCHAIN_PATH=~/Vibrante4.0_RC1/toolchains/tegra-4.9-nv export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE TOOLCHAIN_PATH KERN_DIR PLATFORM_TOPDIR" Change-Id: If58a0fcbe01daa9a55dd041b79a9d80a90fde284 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-nvidia-extras')
-rw-r--r--meta-nvidia-extras/conf/layer.conf32
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend32
-rw-r--r--meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf4
-rw-r--r--meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend28
-rw-r--r--meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend4
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend23
-rw-r--r--meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend23
-rw-r--r--meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch18
-rw-r--r--meta-nvidia-extras/recipes/systemd/systemd_%.bbappend1
-rw-r--r--meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend12
-rw-r--r--meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend9
11 files changed, 0 insertions, 186 deletions
diff --git a/meta-nvidia-extras/conf/layer.conf b/meta-nvidia-extras/conf/layer.conf
deleted file mode 100644
index aa447a53..00000000
--- a/meta-nvidia-extras/conf/layer.conf
+++ /dev/null
@@ -1,32 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-# We have a conf and classes directory, append to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
- ${LAYERDIR}/recipes*/*/*.bbappend \
-"
-
-BBFILE_COLLECTIONS += "b2qt_nvidia"
-BBFILE_PATTERN_b2qt_nvidia := "^${LAYERDIR}/"
-BBFILE_PRIORITY_b2qt_nvidia = "20"
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
deleted file mode 100644
index 86f0571a..00000000
--- a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-FILES_${PN} += "etc/connman/main.conf"
-
-SRC_URI += "file://main.conf \
- "
-
-do_install_append() {
- install -d ${D}${sysconfdir}/connman
- install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
-}
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf b/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
deleted file mode 100644
index a1e45b95..00000000
--- a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf
+++ /dev/null
@@ -1,4 +0,0 @@
-[General]
-PreferredTechnologies=ethernet,wifi,cellular
-NetworkInterfaceBlacklist=eth0
-
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
deleted file mode 100644
index f9d9cc6b..00000000
--- a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
-do_kernel_defconfig_prepend_tegra-t18x () {
-}
-
-do_install_append_tegra-t18x () {
- s=$(readlink -m "${S}")
- kernsrc="${STAGING_KERNEL_DIR}"
-
- if [ "${s}" != "${kernsrc}" ]; then
- mkdir -p "${kernsrc}"
- rm -rf "${kernsrc}"
- mv "${S}" "${STAGING_KERNEL_DIR}"
- ln -sf "${kernsrc}" "${s}"
- fi
-}
-
-do_compile_prepend_tegra-t18x () {
- if [ -z "${TOOLCHAIN_PATH}" ] ; then
- echo "TOOLCHAIN_PATH must be set"
- exit -1
- fi
-
- export PATH="${TOOLCHAIN_PATH}/usr/bin/aarch64-gnu-linux:${PATH}"
-
- echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
- echo "CONFIG_USB_ACM=m" >> ${B}/.config
-
- make olddefconfig
-}
diff --git a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend b/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend
deleted file mode 100644
index 1800e5ee..00000000
--- a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-RDEPENDS_${PN}_remove_tegra-t18x = "\
-libgbm-dev \
-"
-
diff --git a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
deleted file mode 100644
index cd74ddf6..00000000
--- a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DEPENDS_nvidia-logan += "graphics-headers"
-PACKAGECONFIG_nvidia-logan += "kms"
diff --git a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
deleted file mode 100644
index 97acf20d..00000000
--- a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
-COMPATIBLE_MACHINE_aarch64 = "(.*)"
diff --git a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
deleted file mode 100644
index 629ccf40..00000000
--- a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 97a29d6..b0e4060 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*],
- -Wno-gnu-variable-sized-type-not-at-end \
- ])])
-
--AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
-- [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
-- -flto -ffat-lto-objects])],
-- [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
- AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
-
- AS_CASE([$CFLAGS], [*-O[[12345\ ]]*],
---
-2.5.0
-
diff --git a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend b/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
deleted file mode 100644
index d86ee9d3..00000000
--- a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_tegra-t18x := "${THISDIR}/${PN}:"
diff --git a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
deleted file mode 100644
index 85a29965..00000000
--- a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
-GRAPHICS_PACKAGES = " \
-virtual/libgles2 \
-virtual/libegl \
-virtual/egl \
-libgbm \
-libgbm-dev \
-"
-
-PROVIDES_append = " ${GRAPHICS_PACKAGES}"
-RPROVIDES_append_${PN} = " ${GRAPHICS_PACKAGES}"
-CONFLICTS_append_${PN} = " ${GRAPHICS_PACKAGES}"
-REPLACES_append_${PN} = " ${GRAPHICS_PACKAGES}"
diff --git a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend b/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend
deleted file mode 100644
index db0da648..00000000
--- a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-EXTRA_PROVIDES = " \
-virtual/wayland-native \
-wayland-native \
-"
-
-PROVIDES_append = "${EXTRA_PROVIDES}"
-RPROVIDES_append_${PN} = "${EXTRA_PROVIDES}"
-CONFLICTS_append_${PN} = "${EXTRA_PROVIDES}"
-REPLACES_append_${PN} = "${EXTRA_PROVIDES}"