aboutsummaryrefslogtreecommitdiffstats
path: root/meta-smx6-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-01-19 11:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-01-31 08:53:15 +0000
commitc0c98ab5cc94b914b4df4382e7aee5bc2a1cb263 (patch)
treec128a7b853539029f5c1014e72b2570a3e6f3f1a /meta-smx6-extras
parent07b4960e438f4eb772dde4d1ccac153785cf151e (diff)
kontron: update SMARC-sAMX6i BSP to r03.00
Change-Id: Ia33509ecbbc9394b7cbdcd548abb0f6f28cf3c73 Reviewed-by: Rainer Keller <Rainer.Keller@qt.io>
Diffstat (limited to 'meta-smx6-extras')
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch52
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch59
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch31
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend (renamed from meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend)16
-rw-r--r--meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend32
-rw-r--r--meta-smx6-extras/recipes/perf/perf.bbappend30
-rw-r--r--meta-smx6-extras/recipes/qt5/qtbase_git.bbappend30
7 files changed, 94 insertions, 156 deletions
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
deleted file mode 100644
index ee61a743..00000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From ef372125fd64fc181869be4cf528488f9e8b46c2 Mon Sep 17 00:00:00 2001
-From: Behan Webster <behanw@converseincode.com>
-Date: Wed, 24 Sep 2014 01:06:46 +0100
-Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
-
-With compilers which follow the C99 standard (like modern versions of gcc and
-clang), "extern inline" does the wrong thing (emits code for an externally
-linkable version of the inline function). In this case using static inline
-and removing the NULL version of return_address in return_address.c does
-the right thing.
-
-Signed-off-by: Behan Webster <behanw@converseincode.com>
-Reviewed-by: Mark Charlebois <charlebm@gmail.com>
-Acked-by: Steven Rostedt <rostedt@goodmis.org>
-Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
----
- arch/arm/include/asm/ftrace.h | 2 +-
- arch/arm/kernel/return_address.c | 5 -----
- 2 files changed, 1 insertion(+), 6 deletions(-)
-
-diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
-index f89515a..2bb8cac 100644
---- a/arch/arm/include/asm/ftrace.h
-+++ b/arch/arm/include/asm/ftrace.h
-@@ -45,7 +45,7 @@ void *return_address(unsigned int);
-
- #else
-
--extern inline void *return_address(unsigned int level)
-+static inline void *return_address(unsigned int level)
- {
- return NULL;
- }
-diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
-index fafedd8..f6aa84d 100644
---- a/arch/arm/kernel/return_address.c
-+++ b/arch/arm/kernel/return_address.c
-@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
- #warning "TODO: return_address should use unwind tables"
- #endif
-
--void *return_address(unsigned int level)
--{
-- return NULL;
--}
--
- #endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
-
- EXPORT_SYMBOL_GPL(return_address);
---
-1.9.1
-
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
deleted file mode 100644
index 064e28b0..00000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From eb38d22ea05961666878dfb88c68629eacfb1399 Mon Sep 17 00:00:00 2001
-From: Behan Webster <behanw@converseincode.com>
-Date: Tue, 3 Sep 2013 22:27:26 -0400
-Subject: [PATCH] ARM: LLVMLinux: Change "extern inline" to "static inline" in
- glue-cache.h
-
-With compilers which follow the C99 standard (like modern versions of gcc and
-clang), "extern inline" does the wrong thing (emits code for an externally
-linkable version of the inline function). "static inline" is the correct choice
-instead.
-
-Author: Behan Webster <behanw@converseincode.com>
-Signed-off-by: Behan Webster <behanw@converseincode.com>
-Reviewed-by: Mark Charlebois <charlebm@gmail.com>
----
- arch/arm/include/asm/glue-cache.h | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/arch/arm/include/asm/glue-cache.h b/arch/arm/include/asm/glue-cache.h
-index c81adc0..a3c24cd 100644
---- a/arch/arm/include/asm/glue-cache.h
-+++ b/arch/arm/include/asm/glue-cache.h
-@@ -130,22 +130,22 @@
- #endif
-
- #ifndef __ASSEMBLER__
--extern inline void nop_flush_icache_all(void) { }
--extern inline void nop_flush_kern_cache_all(void) { }
--extern inline void nop_flush_kern_cache_louis(void) { }
--extern inline void nop_flush_user_cache_all(void) { }
--extern inline void nop_flush_user_cache_range(unsigned long a,
-+static inline void nop_flush_icache_all(void) { }
-+static inline void nop_flush_kern_cache_all(void) { }
-+static inline void nop_flush_kern_cache_louis(void) { }
-+static inline void nop_flush_user_cache_all(void) { }
-+static inline void nop_flush_user_cache_range(unsigned long a,
- unsigned long b, unsigned int c) { }
-
--extern inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
--extern inline int nop_coherent_user_range(unsigned long a,
-+static inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
-+static inline int nop_coherent_user_range(unsigned long a,
- unsigned long b) { return 0; }
--extern inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
-+static inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
-
--extern inline void nop_dma_flush_range(const void *a, const void *b) { }
-+static inline void nop_dma_flush_range(const void *a, const void *b) { }
-
--extern inline void nop_dma_map_area(const void *s, size_t l, int f) { }
--extern inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
-+static inline void nop_dma_map_area(const void *s, size_t l, int f) { }
-+static inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
- #endif
-
- #ifndef MULTI_CACHE
---
-1.9.1
-
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch b/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch
deleted file mode 100644
index c61a4dc1..00000000
--- a/meta-smx6-extras/recipes/linux/linux-smx6/0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 56e321cd19ee4909ca623ce1c351c966904123a9 Mon Sep 17 00:00:00 2001
-From: Pantelis Antoniou <panto@antoniou-consulting.com>
-Date: Fri, 4 Jan 2013 00:32:33 +0200
-Subject: [PATCH] arm: Export cache flush management symbols when !MULTI_CACHE
-
-When compiling a kernel without CONFIG_MULTI_CACHE enabled the
-dma access functions end up not being exported. Fix it.
-
-Signed-off-by: Pantelis Antoniou <panto@antoniou-consulting.com>
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- arch/arm/kernel/setup.c | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
-diff --git a/arch/arm/kernel/setup.c b/arch/arm/kernel/setup.c
-index 1e8b030..c6a9a61 100644
---- a/arch/arm/kernel/setup.c
-+++ b/arch/arm/kernel/setup.c
-@@ -1080,3 +1080,12 @@ const struct seq_operations cpuinfo_op = {
- .stop = c_stop,
- .show = c_show
- };
-+
-+/* export the cache management functions */
-+#ifndef MULTI_CACHE
-+
-+EXPORT_SYMBOL(__glue(_CACHE,_dma_map_area));
-+EXPORT_SYMBOL(__glue(_CACHE,_dma_unmap_area));
-+EXPORT_SYMBOL(__glue(_CACHE,_dma_flush_range));
-+
-+#endif
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend b/meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend
index 574e60b3..c8222b9a 100644
--- a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
+++ b/meta-smx6-extras/recipes/linux/linux-smx6_4.10.11.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2016 The Qt Company Ltd.
+## Copyright (C) 2018 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,19 +27,7 @@
##
############################################################################
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch \
- file://0001-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch \
- file://0001-arm-Export-cache-flush-management-symbols-when-MULTI.patch \
- "
-
-do_preconfigure_prepend() {
- sed -e '/CONFIG_USB_FUNCTIONFS_ETH=/d' \
- -e '/CONFIG_USB_FUNCTIONFS_RNDIS=/d' \
- -i ${WORKDIR}/defconfig
-
+do_configure_prepend() {
echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
echo "CONFIG_CGROUPS=y" >> ${WORKDIR}/defconfig
}
diff --git a/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend b/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend
new file mode 100644
index 00000000..9f11d6a7
--- /dev/null
+++ b/meta-smx6-extras/recipes/mesa/mesa-etnaviv_17.0.3.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+EXTRA_OECONF += "--disable-libunwind"
+
+PROVIDES += "virtual/libgbm"
diff --git a/meta-smx6-extras/recipes/perf/perf.bbappend b/meta-smx6-extras/recipes/perf/perf.bbappend
new file mode 100644
index 00000000..afbed0da
--- /dev/null
+++ b/meta-smx6-extras/recipes/perf/perf.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+EXTRA_OEMAKE += "NO_JVMTI=1"
diff --git a/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend b/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend
new file mode 100644
index 00000000..602782e2
--- /dev/null
+++ b/meta-smx6-extras/recipes/qt5/qtbase_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG += "gbm kms"