aboutsummaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-10-13 13:06:09 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-10-14 10:22:37 +0000
commitf956591bbe246fae0dc4ed9b6d911bcec526463f (patch)
tree6a0da0066d8b9850cf913287ea55872041c67411 /meta-tegra-extras
parent776b174f4b54f8913933a67392f1cc3fa1085506 (diff)
Revert "tegra: update to latest vibrante pdk"
Problems with eglfs, so revert back to previous PDK. This reverts commit 323408406d9133a5462a24fea4ec86e649088180. Change-Id: I3ee36809cb823aefdc03f8a24d052c2a76f308db Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc11
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend40
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
new file mode 100644
index 00000000..6fe139e9
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: libdrm
+Description: Userspace interface to kernel DRM services
+Version: 2.4.66
+Libs: -L${libdir} -ldrm
+Cflags: -I${includedir} -I${includedir}/libdrm
+
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
new file mode 100644
index 00000000..f346a6b5
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
@@ -0,0 +1,40 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://libdrm.pc"
+SRC_URI_remove_nvidia-logan = "file://${PLATFORM_TOPDIR}/include/drm_fourcc.h"
+
+do_install_append() {
+ install -d ${D}/usr/lib/pkgconfig
+ install -m 0776 ${WORKDIR}/libdrm.pc ${D}/usr/lib/pkgconfig/libdrm.pc
+}
+
+PACKAGES += "${PN}-dev"