aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@pelagicore.com>2018-01-19 17:13:54 +0100
committerDominik Holland <dominik.holland@pelagicore.com>2018-02-05 09:23:46 +0000
commit0c5437b2baf2a8241665a5bdfcb7dd0e88ad9f34 (patch)
tree70b0372e843521cd7cb7f98811960dcd0dbd1500 /recipes-qt
parent765598f189f50f905627a73cfabb29acae405a9a (diff)
qtivi: Fix the broken python3 binary inside an yocto SDK
QtIvi creates a virtualenv using the python3 binary from the native sysroot. This virtualenv is also used for the SDK. As it is not intended for the SDK it is using the wrong interpreter location. This workaround installs the python3 binary into the nativesdk sysroot where the qtivi nativesdk recipe can pick it up and copy it into its virtualenv. This needs to be improved in future versions and is discussed here: AUTOSUITE-176 Task-number: AUTOSUITE-179 Change-Id: Ib134231204cc8c6a56f2a93bedb553ecbcbd9123 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> Reviewed-by: Tobias Olausson <tobias.olausson@pelagicore.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/automotive/qtivi_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 40cfbf1f..b5536a48 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -89,6 +89,19 @@ do_install_prepend() {
set_python_paths
}
+# This needs a modified python3 recipe which copies the binary into a path where this recipe can pick it up
+# This is needed to provide a proper executable using the correct interpreter in the SDK.
+# See https://bugreports.qt.io/browse/AUTOSUITE-176
+do_install_append_class-nativesdk() {
+ export IVIGENERATOR_ENABLED="${@bb.utils.contains("PACKAGECONFIG", "ivigenerator-native", "1", "0", d)}"
+
+ if [ "${IVIGENERATOR_ENABLED}" = "1" ]; then
+ cp ${STAGING_BINDIR}/qt5/python3* ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/
+ rm -f ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
+ ln -sf python3 ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
+ fi
+}
+
BBCLASSEXTEND += "native nativesdk"