aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-09-26 13:15:00 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-09-26 13:21:41 +0000
commit545bebca0722c21c4cd61c47260202bda20f2db4 (patch)
tree82503d6da46d47cb63dbb69f70739c710588f750 /recipes-qt
parent81831558b4dfdeb5030d6519f29d9ce122a434ce (diff)
qtquickcompiler: fix path for QT_HOST_BINS
Bitbake builds need to use QT_HOST_BINS/get for getting the correct path to the host tools. Change it for qtquickcompiler.prf so that project can use CONFIG+=qtquickcompiler without need to have CONFIG+=no_qtquickcompiler_depend as well. Change-Id: I5196e06f249531833fccca6b0b6a213016270ab6 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler-sdk.bb3
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb5
2 files changed, 8 insertions, 0 deletions
diff --git a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
index 98c3debf..b21b2ceb 100644
--- a/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
+++ b/recipes-qt/qt5-addons/qtquickcompiler-sdk.bb
@@ -56,6 +56,9 @@ do_install() {
install -d ${D}${OE_QMAKE_PATH_BINS}
install -m 0755 ${THISDIR}/qtquickcompiler-sdk/bin/${NATIVESDK_BINARY} ${D}${OE_QMAKE_PATH_BINS}
fi
+
+ # Use the EffectivePath instead of installation path
+ sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
}
do_install_append_mingw32() {
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
index e6843648..ae3e87f3 100644
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -43,4 +43,9 @@ S = "${WORKDIR}/git"
DEPENDS = "qtbase qtdeclarative"
+do_install_append() {
+ # Use the EffectivePath instead of installation path
+ sed -i -e 's|QT_HOST_BINS|QT_HOST_BINS/get|' ${D}${OE_QMAKE_PATH_ARCHDATA}/mkspecs/features/qtquickcompiler.prf
+}
+
BBCLASSEXTEND = "native nativesdk"