aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-11-17 13:38:14 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-11-17 13:39:10 +0000
commit86e061a015a75185d9e5cef8d20c3e230c3c7424 (patch)
tree4bacf69b1bf57260bcec2dc3ad7a845f67201fc0 /recipes-qt
parent0af8477aaa48831eff9669466413266e8a26f98e (diff)
qbsp: various improvements to qbsp creation
Now using the same component name and installation paths as are done with components from online installer. Modify the component description from recipe, so it's different for boot2qt and automotive qbsps. Change-Id: Ie43fa00e438b9ec2e219eda052f728e7c0754644 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/meta/meta-b2qt-automotive-qbsp.bb7
-rw-r--r--recipes-qt/meta/meta-b2qt-embedded-qbsp.bb5
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
index 3f86016b..a9da4568 100644
--- a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
+++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
@@ -38,11 +38,12 @@ S = "${WORKDIR}"
inherit qbsp
-PV = "1.1"
+PV := "${@d.getVar('PV', True)[0:5]}"
+QBSP_NAME = "Qt Automotive"
QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}"
-QBSP_INSTALLER_COMPONENT = "qt.automotive.10.yocto.${QBSP_MACHINE}"
-QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Automotive/${MACHINE}"
+QBSP_INSTALLER_COMPONENT = "automotive.10.yocto.${QBSP_MACHINE}"
+QBSP_INSTALL_PATH = "/${PV}/Automotive/${MACHINE}"
QBSP_SDK_TASK = "meta-toolchain-b2qt-automotive-qt5-sdk"
QBSP_IMAGE_TASK = "b2qt-automotive-qt5-image"
diff --git a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
index 6fe8bf19..d6def0fa 100644
--- a/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
+++ b/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
@@ -40,10 +40,11 @@ inherit qbsp
PV := "${@d.getVar('PV', True)[0:5]}"
-VERSION_SHORT = "${@d.getVar('QT_MODULE_BRANCH', True).replace('.','')}"
+VERSION_SHORT = "${@d.getVar('PV', True).replace('.','')}"
+QBSP_NAME = "Boot to Qt"
QBSP_MACHINE = "${@d.getVar('MACHINE', True).replace('-','')}"
QBSP_INSTALLER_COMPONENT = "qt.embedded.b2qt.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
-QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Boot2Qt/${MACHINE}"
+QBSP_INSTALL_PATH = "/${PV}/Boot2Qt/${MACHINE}"
QBSP_SDK_TASK = "meta-toolchain-b2qt-embedded-qt5-sdk"
QBSP_IMAGE_TASK = "b2qt-embedded-qt5-image"