aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-01-19 11:10:35 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-01-23 11:09:49 +0000
commitb6695b047a17ed878f94501b7c326322be2f77bf (patch)
treed09e00bf07277147e33f169a955d850a19c602f8 /recipes-qt
parentd075186a68fc5fb55944e47dc9359064cac131be (diff)
multiscreen-demo: update revision and fix startup
Update to latest revision. Don't use the provided start.sh script as it's hardcoded for NVIDIA HW. Task-number: AUTOSUITE-182 Change-Id: I1a7498da31ae49bec34426bee3af8517b7333fb4 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/automotive/multiscreen-demo/automotivedemo.service12
-rw-r--r--recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service13
-rw-r--r--recipes-qt/automotive/multiscreen-demo_git.bb14
3 files changed, 33 insertions, 6 deletions
diff --git a/recipes-qt/automotive/multiscreen-demo/automotivedemo.service b/recipes-qt/automotive/multiscreen-demo/automotivedemo.service
new file mode 100644
index 00000000..af232136
--- /dev/null
+++ b/recipes-qt/automotive/multiscreen-demo/automotivedemo.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=AutomotiveDemo
+After=dbus.service dbus-session.service systemd-user-sessions.service
+Conflicts=neptune.service
+
+[Service]
+ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
+Restart=on-failure
+WorkingDirectory=/opt/automotivedemo
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service b/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service
new file mode 100644
index 00000000..1025cc17
--- /dev/null
+++ b/recipes-qt/automotive/multiscreen-demo/tegra-t18x/automotivedemo.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=AutomotiveDemo
+After=dbus.service dbus-session.service systemd-user-sessions.service
+Conflicts=neptune.service
+
+[Service]
+ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
+Restart=on-failure
+WorkingDirectory=/opt/automotivedemo
+Environment=QT_QPA_EGLFS_KMS_CONFIG=kms_config.json
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/multiscreen-demo_git.bb b/recipes-qt/automotive/multiscreen-demo_git.bb
index 0c9a2bb3..7ce28b0d 100644
--- a/recipes-qt/automotive/multiscreen-demo_git.bb
+++ b/recipes-qt/automotive/multiscreen-demo_git.bb
@@ -37,13 +37,15 @@ require recipes-qt/qt5/qt5-git.inc
QT_GIT = "git://code.qt.io/qt-apps"
QT_MODULE_BRANCH = "master"
-SRC_URI += "git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets"
+SRC_URI += "\
+ git://github.com/qtproject/qt-apps-demo-assets;protocol=git;name=assets;destsuffix=git/demo-assets \
+ file://automotivedemo.service \
+ "
-SRCREV_multiscreen = "f4cd6b9667b4649b4ef8b4bb645850b05aceebde"
+SRCREV_multiscreen-demo = "e7126b85bacab4571da6d8b5ba8517f3bb0abd47"
SRCREV_assets = "0d47d21f082d6c9e355a55809ebd38a31ea02264"
-SRCREV_FORMAT = "multiscreen_assets"
-SRCREV = "${SRCREV_multiscreen}"
+SRCREV_FORMAT = "multiscreen-demo_assets"
DEPENDS = "qtbase qtdeclarative qt3d"
RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard"
@@ -51,10 +53,10 @@ RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard"
EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
do_install_append() {
- install -m 0755 ${S}/start.sh ${D}/opt/automotivedemo/
+ rm ${D}/opt/automotivedemo/start.sh
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${S}/scripts/automotivedemo.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${WORKDIR}/automotivedemo.service ${D}${systemd_system_unitdir}/
}
FILES_${PN} += "\