aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-10-31 10:49:02 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-11-08 16:53:33 +0000
commitdf17ffab8615d5de8659ec8f285e2a92b28cd671 (patch)
treee9647a5a5c69dcf0ba5bf5ee913e4859b30bf3db /recipes-qt
parent8d075eea57b66c672aead741d591fb7b71dfb170 (diff)
automotive: update revisions
Update all automotive components. Merge changes done in pyro branch. Change-Id: I9a084b69ff7399c244098a336f0a3a112859fa17 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/automotive/gammaray_git.bb6
-rw-r--r--recipes-qt/automotive/neptune-ui/neptune.service4
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb14
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb6
-rw-r--r--recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch29
-rw-r--r--recipes-qt/automotive/qtivi_git.bb5
6 files changed, 48 insertions, 16 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
index 63170408..1de4c09d 100644
--- a/recipes-qt/automotive/gammaray_git.bb
+++ b/recipes-qt/automotive/gammaray_git.bb
@@ -8,11 +8,11 @@ inherit cmake_qt5
SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
-BRANCH = "2.7"
-SRCREV = "a22da6d63cab08f3ef8588611fdbda3f96731efe"
+BRANCH = "5.9"
+SRCREV = "ff53d7328d6db17dcb6486bb98b02a2f107b4066"
PV = "${BRANCH}+git${SRCPV}"
-DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml \
+DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
S = "${WORKDIR}/git"
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service
index 7793d0bf..ef733246 100644
--- a/recipes-qt/automotive/neptune-ui/neptune.service
+++ b/recipes-qt/automotive/neptune-ui/neptune.service
@@ -3,9 +3,9 @@ Description=Neptune
After=dbus.service dbus-session.service systemd-user-sessions.service
[Service]
-ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml Main.qml
+ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml
Restart=on-failure
-WorkingDirectory=/opt/neptune
+WorkingDirectory=/opt/neptune-ui
[Install]
WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
index b7ca95d4..e8d01f22 100644
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -29,7 +29,7 @@
DESCRIPTION = "Neptune IVI UI"
LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
-LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82"
inherit qt5-module systemd
require recipes-qt/qt5/qt5-git.inc
@@ -41,13 +41,15 @@ SRC_URI += " \
file://neptune.service \
"
-SRCREV = "6ddea70fd06d78ca7672f18221b91b3e8990aee8"
+SRCREV = "2a242aa65f267d010d8c10b8c5da5a1e728d0551"
-DEPENDS = "qtbase qtdeclarative qttools-native"
-RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard dbus \
+DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager"
+RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \
qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \
${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
+EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt"
+
do_install_append() {
install -m 0755 -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
@@ -56,9 +58,9 @@ do_install_append() {
PACKAGES =+ "${PN}-apps"
RRECOMMENDS_${PN} += "${PN}-apps"
-FILES_${PN}-apps += "/opt/neptune/apps"
+FILES_${PN}-apps += "/opt/neptune-ui/apps"
FILES_${PN} += "\
- /opt/neptune \
+ /opt/neptune-ui \
"
SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index 52ee20e2..5b112b58 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71"
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "f472ef3662cf0a9bc2bf727c7cef18fd884df5a2"
+SRCREV = "57ff870b0790e1e1feb3421cdfb46dff82878825"
DEPENDS = "qtbase qtdeclarative libyaml libarchive \
${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
@@ -60,8 +60,8 @@ FILES_${PN} += "\
BBCLASSEXTEND += "nativesdk"
-DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale"
-DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale"
+DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale nativesdk-libarchive"
+DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale nativesdk-libarchive"
EXTRA_QMAKEVARS_PRE_class-nativesdk += "\
-config tools-only \
diff --git a/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
new file mode 100644
index 00000000..9f6c0c02
--- /dev/null
+++ b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch
@@ -0,0 +1,29 @@
+From b4ed8c9d4a391771cba485bfa685147126260dc2 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 7 Sep 2017 10:24:11 +0300
+Subject: [PATCH] Use QT_HOST_BINS/get for getting correct path
+
+Patch QT_HOST_BINS same way as is done it qtbase for getting
+the EffectivePath instead of installation path.
+
+Change-Id: I3e9c04019c432e182dcb5c0898275173f20de1e2
+---
+ mkspecs/features/ivigenerator.prf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mkspecs/features/ivigenerator.prf b/mkspecs/features/ivigenerator.prf
+index 65c497e..7634355 100644
+--- a/mkspecs/features/ivigenerator.prf
++++ b/mkspecs/features/ivigenerator.prf
+@@ -31,9 +31,9 @@ QFACE_YAML = $$QFACE_ABS_PWD/$${QFACE_BASE_NAME}.yaml
+ OTHER_FILES += $$QFACE_FILE
+
+ # Detect whether we are using the feature inside the qtivi repository
+-VIRTUALENV_PATH = $$[QT_HOST_BINS]/ivigenerator/qtivi_qface_virtualenv
++VIRTUALENV_PATH = $$[QT_HOST_BINS/get]/ivigenerator/qtivi_qface_virtualenv
+ INTERNAL_VIRTUALENV_PATH = $$QTIVI_BUILD_ROOT/src/tools/ivigenerator/qtivi_qface_virtualenv
+-IVI_GENERATOR_PATH = $$[QT_HOST_BINS]/ivigenerator
++IVI_GENERATOR_PATH = $$[QT_HOST_BINS/get]/ivigenerator
+ QTEST_ENVIRONMENT = $$upper($$(QTEST_ENVIRONMENT))
+
+ # Try to use the internal virtualenv when building qtivi
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 0f49d5dc..3eb48e5e 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -47,10 +47,11 @@ QT_MODULE_BRANCH_QFACE = "upstream/develop"
SRC_URI += " \
${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \
+ file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
"
-SRCREV_qtivi = "3205b6e8f57273096ae60d8f6fcdbe597c350393"
-SRCREV_qface = "b1d96d85a7c43ac74335b9a1a99a68507047f5bc"
+SRCREV_qtivi = "705acb8d595d772778dd4985b762ed6a604473d9"
+SRCREV_qface = "295824c8df7f74af8f3d1f368ec15942e6622f22"
SRCREV = "${SRCREV_qtivi}"
SRCREV_FORMAT = "qtivi_qface"