aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-boot2qt-distro/conf/distro/include/raspberrypi.inc3
-rw-r--r--meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend7
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demolauncher_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb2
4 files changed, 5 insertions, 9 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
index bd792593..6fc24878 100644
--- a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
+++ b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
@@ -34,6 +34,7 @@ DEPLOY_CONF_NAME:raspberrypi3 = "Raspberry Pi 3"
DEPLOY_CONF_NAME:raspberrypi4 = "Raspberry Pi 4"
DEPLOY_CONF_NAME:raspberrypi4-64 = "Raspberry Pi 4 64-bit"
DEPLOY_CONF_NAME:raspberrypi5 = "Raspberry Pi 5"
+DEPLOY_CONF_NAME:raspberrypi-armv8 ="Raspberry Pi Development Boards (64bit)"
IMAGE_FSTYPES += "wic.xz"
@@ -62,7 +63,7 @@ dtparam=audio=on \n\
"
# enable device mode from usb-c
-ENABLE_DWC2_PERIPHERAL:raspberrypi4 = "1"
+ENABLE_DWC2_PERIPHERAL = "1"
# additional memory for GPU
GPU_MEM_256 = "128"
diff --git a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
index 21c39157..242b863b 100644
--- a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2019 The Qt Company Ltd.
+## Copyright (C) 2024 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -37,11 +37,10 @@ do_configure:append() {
echo "QT_WAYLAND_HARDWARE_INTEGRATION=linux-dmabuf-unstable-v1" >> ${WORKDIR}/defaults
}
-do_configure:append:raspberrypi5() {
+do_configure:append() {
echo "QT_QPA_EGLFS_KMS_CONFIG=/etc/kms.conf" >> ${WORKDIR}/defaults
}
-do_install:append:raspberrypi5() {
+do_install:append() {
install -m 0644 ${WORKDIR}/kms.conf ${D}${sysconfdir}/
}
-
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demolauncher_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demolauncher_git.bb
index 27892b25..896b46e6 100644
--- a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demolauncher_git.bb
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demolauncher_git.bb
@@ -37,8 +37,6 @@ LIC_FILES_CHKSUM = " \
inherit qt6-cmake systemd
require recipes-qt/qt6/qt6-git.inc
-QT_GIT = "git://codereview.qt-project.org"
-QT_GIT_PROTOCOL = "http"
QT_GIT_PROJECT = "qt-apps"
QT_MODULE = "boot2qt-launcher"
QT_MODULE_BRANCH = "dev"
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb
index a574adf0..a0c9588f 100644
--- a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb
@@ -34,8 +34,6 @@ LIC_FILES_CHKSUM = "file://main.cpp;md5=5c11ee2d9fe17c24e80b866d1b758458;beginli
inherit qt6-cmake systemd
require recipes-qt/qt6/qt6-git.inc
-QT_GIT = "git://codereview.qt-project.org"
-QT_GIT_PROTOCOL = "http"
QT_GIT_PROJECT = "qt-apps"
QT_MODULE = "boot2qt-demos"
QT_MODULE_BRANCH = "dev"