aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/deploy-conf.bbclass8
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb2
2 files changed, 7 insertions, 3 deletions
diff --git a/classes/deploy-conf.bbclass b/classes/deploy-conf.bbclass
index 228b1e20..22c6ef7d 100644
--- a/classes/deploy-conf.bbclass
+++ b/classes/deploy-conf.bbclass
@@ -29,15 +29,19 @@
inherit image_types
+IMAGE_DEPENDS_conf = "qtbase-native"
+
DEPLOY_CONF_NAME ?= "${MACHINE}"
DEPLOY_CONF_TYPE ?= "Boot2Qt"
IMAGE_CMD_conf() {
+ QT_VERSION=$(qmake -query QT_VERSION)
cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF
-[${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}]
+[${DEPLOY_CONF_NAME}]
platform=${MACHINE}
+product=${DEPLOY_CONF_TYPE}
+qt=Qt $QT_VERSION
os=linux
-board=
imagefile=${IMAGE_LINK_NAME}.img
asroot=true
EOF
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 67819d76..7c6c2dec 100644
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
PR = "r0"
-DEPLOY_CONF_TYPE = "Automotive"
+DEPLOY_CONF_TYPE = "Qt Automotive Suite 2.0.1"
IMAGE_FEATURES += "\
package-management \