aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-24 08:43:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-24 08:43:51 +0000
commit51e07805e0cf8f53bc9609854d1afd5e51494151 (patch)
treeb76b4ff591d489b33886044dd67a94852c74ea3b
parentc67abd66ff15feeaae5acc2688b932e5dec72317 (diff)
qtbase: replace the fix for gcc-4.8 with the one from upstreamupstream/jansa/master-5.12
* fixes: | In file included from ../include/QtCore/qendian.h:1:0, | from /OE/build/oe-core/tmp-glibc/work/x86_64-linux/qtbase-native/5.12.0+gitAUTOINC+13ed06640c-r0/git/src/corelib/codecs/qutfcodec.cpp:43: | ../include/QtCore/../../../git/src/corelib/global/qendian.h: In instantiation of �constexpr Float qbswapFloatHelper(Float) [with Float = qfloat16]�: | ../include/QtCore/../../../git/src/corelib/global/qendian.h:167:36: required from here | ../include/QtCore/../../../git/src/corelib/global/qendian.h:163:1: error: body of constexpr function �constexpr Float qbswapFloatHelper(Float) [with Float = qfloat16]� not a return-statement | } | ^ | ../include/QtCore/../../../git/src/corelib/global/qendian.h: In instantiation of �constexpr Float qbswapFloatHelper(Float) [with Float = float]�: | ../include/QtCore/../../../git/src/corelib/global/qendian.h:172:29: required from here | ../include/QtCore/../../../git/src/corelib/global/qendian.h:163:1: error: body of constexpr function �constexpr Float qbswapFloatHelper(Float) [with Float = float]� not a return-statement | ../include/QtCore/../../../git/src/corelib/global/qendian.h: In instantiation of �constexpr Float qbswapFloatHelper(Float) [with Float = double]�: | ../include/QtCore/../../../git/src/corelib/global/qendian.h:177:29: required from here | ../include/QtCore/../../../git/src/corelib/global/qendian.h:163:1: error: body of constexpr function �constexpr Float qbswapFloatHelper(Float) [with Float = double]� not a return-statement Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb6
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb6
-rw-r--r--recipes-qt/qt5/qtbase/0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch59
-rw-r--r--recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch49
-rw-r--r--recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
7 files changed, 69 insertions, 59 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 6c9853ea..dc1fc41b 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.3
+# 5.12.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -43,12 +43,12 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
- file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
+ file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.3
+# 5.12.meta-qt5-native.4
SRC_URI += " \
file://0020-Always-build-uic-and-qvkgen.patch \
"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index d224487c..9f0fca51 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.3
+# 5.12.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -38,12 +38,12 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
- file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
+ file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.3
+# 5.12.meta-qt5-native.4
SRC_URI += " \
file://0020-Always-build-uic-and-qvkgen.patch \
"
diff --git a/recipes-qt/qt5/qtbase/0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch b/recipes-qt/qt5/qtbase/0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch
new file mode 100644
index 00000000..21e3207d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch
@@ -0,0 +1,59 @@
+From 4bcd7b1c6e06cfaef1a52795df007f1a9372eeed Mon Sep 17 00:00:00 2001
+From: Ville Voutilainen <ville.voutilainen@qt.io>
+Date: Wed, 21 Nov 2018 14:07:18 +0200
+Subject: [PATCH] Fix compilation of qendian's qswap specializations on gcc 4.8
+
+Task-number: QTBUG-71945
+Change-Id: Icf2b75c72946f57ebffc880c9238531dea13ab5b
+Reviewed-by: Ivan Komissarov <ABBAPOH@gmail.com>
+Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
+---
+ src/corelib/global/qendian.h | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/src/corelib/global/qendian.h b/src/corelib/global/qendian.h
+index 0e67a1ab8e..f2e5833468 100644
+--- a/src/corelib/global/qendian.h
++++ b/src/corelib/global/qendian.h
+@@ -162,17 +162,17 @@ Float qbswapFloatHelper(Float source)
+ return qFromUnaligned<Float>(&temp);
+ }
+
+-template <> inline qfloat16 qbswap<qfloat16>(qfloat16 source)
++inline qfloat16 qbswap(qfloat16 source)
+ {
+ return qbswapFloatHelper(source);
+ }
+
+-template <> inline float qbswap<float>(float source)
++inline float qbswap(float source)
+ {
+ return qbswapFloatHelper(source);
+ }
+
+-template <> inline double qbswap<double>(double source)
++inline double qbswap(double source)
+ {
+ return qbswapFloatHelper(source);
+ }
+@@ -185,7 +185,7 @@ template <> inline double qbswap<double>(double source)
+ */
+ template <typename T> inline void qbswap(const T src, void *dest)
+ {
+- qToUnaligned<T>(qbswap<T>(src), dest);
++ qToUnaligned<T>(qbswap(src), dest);
+ }
+
+ template <int Size> void *qbswap(const void *source, qsizetype count, void *dest) noexcept;
+@@ -223,9 +223,9 @@ template <typename T> inline void qFromLittleEndian(const void *source, qsizetyp
+ #else // Q_LITTLE_ENDIAN
+
+ template <typename T> inline Q_DECL_CONSTEXPR T qToBigEndian(T source)
+-{ return qbswap<T>(source); }
++{ return qbswap(source); }
+ template <typename T> inline Q_DECL_CONSTEXPR T qFromBigEndian(T source)
+-{ return qbswap<T>(source); }
++{ return qbswap(source); }
+ template <typename T> inline Q_DECL_CONSTEXPR T qToLittleEndian(T source)
+ { return source; }
+ template <typename T> inline Q_DECL_CONSTEXPR T qFromLittleEndian(T source)
diff --git a/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch b/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch
deleted file mode 100644
index 42c3d2fb..00000000
--- a/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From c10b4df78f56f4ad3db563fe73d0ebece3e5284c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 24 Dec 2018 00:05:06 -0800
-Subject: [PATCH] qendian: Adding Q_DECL_CONSTEXPR to float conversion
- specializations
-
-This fixes build failures seen with gcc 4.8
-Fixes https://bugreports.qt.io/browse/QTBUG-71945
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/corelib/global/qendian.h | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/corelib/global/qendian.h b/src/corelib/global/qendian.h
-index 0e67a1ab8e..75f109f26c 100644
---- a/src/corelib/global/qendian.h
-+++ b/src/corelib/global/qendian.h
-@@ -153,7 +153,7 @@ template <> inline Q_DECL_CONSTEXPR qint8 qbswap<qint8>(qint8 source)
- }
-
- // floating specializations
--template<typename Float>
-+template<typename Float> Q_DECL_CONSTEXPR
- Float qbswapFloatHelper(Float source)
- {
- // memcpy call in qFromUnaligned is recognized by optimizer as a correct way of type prunning
-@@ -162,17 +162,17 @@ Float qbswapFloatHelper(Float source)
- return qFromUnaligned<Float>(&temp);
- }
-
--template <> inline qfloat16 qbswap<qfloat16>(qfloat16 source)
-+template <> inline Q_DECL_CONSTEXPR qfloat16 qbswap<qfloat16>(qfloat16 source)
- {
- return qbswapFloatHelper(source);
- }
-
--template <> inline float qbswap<float>(float source)
-+template <> inline Q_DECL_CONSTEXPR float qbswap<float>(float source)
- {
- return qbswapFloatHelper(source);
- }
-
--template <> inline double qbswap<double>(double source)
-+template <> inline Q_DECL_CONSTEXPR double qbswap<double>(double source)
- {
- return qbswapFloatHelper(source);
- }
diff --git a/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch
index 89ea8778..2d942289 100644
--- a/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From f43c877cc27a1042c5ba898fd3865164a200ce40 Mon Sep 17 00:00:00 2001
+From f8ae183b543b1244fb272f26db330f52e0d53161 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
index 6ac54fdf..733e69ac 100644
--- a/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From f21492a98b2a738e53134be8b7bf8ce44af71712 Mon Sep 17 00:00:00 2001
+From 4d5e38f1b5f42d61428b7984f9f4d7f22ebe2a2e Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3f7ee3c7..5c967d2f 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.3
+# 5.12.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -34,7 +34,7 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
- file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
+ file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
"