aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2024-02-02 09:59:05 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2024-02-05 10:18:57 +0000
commit8725c579085a317c35e625c1feb8a442a382b88a (patch)
tree04b3b86f0b2ca228dd3d26a1b08eb739523ca97c
parent64cce2673cef05cf7b9906087d92210e31e0090d (diff)
parent1ff6fdcfb971e0b5bfd037b937378fc1937b740b (diff)
Merge remote-tracking branch 'upstream/master' into lts-5.15
Also qtwebkit recipe removal reverted as merged change "1ff6fdcf qmake5: Move to EXPORT_FUNCTIONS" fixes build issues. changelog: 1ff6fdcf qmake5: Move to EXPORT_FUNCTIONS 526b61e1 qt5: upgrade to v5.15.12-lts-lgpl f23f1cd3 Revert "qt5: upgrade to v5.15.11-lts-lgpl" 7c4327ac qt5: upgrade to v5.15.11-lts-lgpl 25d86278 conf/layer.conf: Add meta-oe to LAYERDEPENDS 12f1cd76 qtbase: Patch to support xkbcommon 1.6.0 ee5e66ef examples: Update qt5-opengles2-test to most recent commit Change-Id: Ib02a73225f4689cb18c61712a0d3411c5ab7e70c
-rw-r--r--classes/qmake5.bbclass8
-rw-r--r--coin/module_config.yaml1
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-qt/examples/qt5-opengles2-test_git.bb2
4 files changed, 7 insertions, 6 deletions
diff --git a/classes/qmake5.bbclass b/classes/qmake5.bbclass
index befb5bfd..d9b919cd 100644
--- a/classes/qmake5.bbclass
+++ b/classes/qmake5.bbclass
@@ -6,14 +6,16 @@ inherit qmake5_base
QT5TOOLSDEPENDS ?= "qtbase-native"
DEPENDS:prepend = "${QT5TOOLSDEPENDS} "
-do_configure() {
+qmake5_do_configure() {
qmake5_base_do_configure
}
-do_install() {
+qmake5_do_install() {
qmake5_base_do_install
}
-do_install:class-native() {
+qmake5_do_install:class-native() {
qmake5_base_native_do_install
}
+
+EXPORT_FUNCTIONS do_configure do_install
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index 7fee5b15..2d1137c6 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -139,7 +139,6 @@ instructions:
# EXCLUDE FROM WORLD
rm -fv ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
- rm -fv ${SOURCE_DIR}/recipes-qt/qt5/qtwebkit_git.bb
# build only recipes found under recipes-qt
bitbake $(find ${SOURCE_DIR}/recipes-qt -name *.bb | xargs -n1 basename | sed -e 's/\([^._]*\).*/\1/')
diff --git a/conf/layer.conf b/conf/layer.conf
index 8c7aa69f..4f5dde5c 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -27,7 +27,7 @@ BBFILE_PRIORITY_qt5-layer = "7"
# cause compatibility issues with other layers
LAYERVERSION_qt5-layer = "1"
-LAYERDEPENDS_qt5-layer = "core"
+LAYERDEPENDS_qt5-layer = "core openembedded-layer"
LAYERSERIES_COMPAT_qt5-layer = "dunfell gatesgarth hardknott honister kirkstone langdale mickledore nanbield"
diff --git a/recipes-qt/examples/qt5-opengles2-test_git.bb b/recipes-qt/examples/qt5-opengles2-test_git.bb
index f617ee7b..3634fbae 100644
--- a/recipes-qt/examples/qt5-opengles2-test_git.bb
+++ b/recipes-qt/examples/qt5-opengles2-test_git.bb
@@ -13,7 +13,7 @@ DEPENDS = "qtbase qtsensors"
EXCLUDE_FROM_WORLD = "1"
SRC_URI = "git://github.com/smk-embedded/qt5-opengles2-test.git;branch=master;protocol=https"
-SRCREV = "938390507054ed1258345f70ed55770d2fe56176"
+SRCREV = "293ae5cfedf48c97178057932d06db409117e4ad"
S = "${WORKDIR}/git"
inherit qmake5