aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-02-23 08:13:42 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2021-02-25 13:00:46 +0200
commita4dc2f99cdb598b2a11d2ff5b75fb0352627509c (patch)
tree865d7fa4e5183f43c2fca3255db1e86621ea9e7c
parent79c04dff6af6dbf6672268ee2507bfe88475c5f3 (diff)
qtbase: remove scripts that cause file-rdeb QA issuesv6.0.2
Remove unneeded macOS and Android specific scripts that depend on perl and bash which then cause file-rdeps QA issues. Change-Id: I877461fdcffc4fee5b29e929ad8ac2d30a2e980a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit fe0c4887c39ed556d14d7eab1d930629ed7c993f) Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt6/qtbase_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index af39f6a..d2ba6e9 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -124,14 +124,18 @@ EXTRA_OECMAKE_append_class-target = "\
-DQT_AVOID_CMAKE_ARCHIVING_API=ON \
"
-# mkspecs have mac specific scripts that depend on perl and bash
-SKIP_FILEDEPS_${PN}-dev = "1"
-
SYSROOT_DIRS += "${QT6_INSTALL_MKSPECSDIR}"
do_install_append() {
sed -i ${D}${libdir}/cmake/Qt6BuildInternals/QtBuildInternalsExtra.cmake \
-e '/QT_SOURCE_TREE/,+2d'
+
+ # remove mac and android specific scripts that depend on perl and bash
+ # to avoid file-rdeps QA Issue.
+ rm -f ${D}${QT6_INSTALL_LIBEXECDIR}/android_emulator_launcher.sh
+ rm -f ${D}${QT6_INSTALL_MKSPECSDIR}/features/uikit/devices.py
+ rm -f ${D}${QT6_INSTALL_MKSPECSDIR}/features/uikit/device_destinations.sh
+ rm -f ${D}${QT6_INSTALL_MKSPECSDIR}/features/data/mac/objc_namespace.sh
}
do_install_append_class-nativesdk() {