summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHarald Fernengel <harald.fernengel@nokia.com>2010-02-24 11:42:07 +0100
committerHarald Fernengel <harald.fernengel@nokia.com>2010-02-24 11:42:07 +0100
commita3a2e7e57e29c35127be7776548a8a0f07a0efee (patch)
treef4b95da0b17d88b75246080d2920bd6c9e60c7f6 /debian
Initial version of Qt for Maemo 5 homescreen widget loader + example
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/compat1
-rw-r--r--debian/control38
-rw-r--r--debian/qt4-maemo5-homescreen-example.install3
-rw-r--r--debian/qt4-maemo5-homescreen-loader.install1
-rwxr-xr-xdebian/rules43
6 files changed, 98 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ce70308
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,12 @@
+qt4-maemo5-homescreen (4.6.2~git20100224-4maemo1) unstable; urgency=low
+
+ * Fix dependencies
+
+ -- Qt Development Frameworks <qt-info@nokia.com> Wed, 24 Feb 2010 14:29:01 +0200
+
+qt4-maemo5-homescreen (4.6.2~git20100223-4maemo1) unstable; urgency=low
+
+ * Initial package
+
+ -- Qt Development Frameworks <qt-info@nokia.com> Tue, 23 Feb 2010 14:29:01 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ffe525d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,38 @@
+Source: qt4-maemo5-homescreen
+Section: libs
+Priority: optional
+Maintainer: Qt Development Frameworks <qt-info@nokia.com>
+Uploaders: Harald Fernengel <harald.fernengel@nokia.com>
+Build-Depends: libqt4-maemo5-dev, libhildon1-dev, libhildondesktop1-dev
+Standards-Version: 3.7.3
+
+Package: qt4-maemo5-homescreen-loader
+Architecture: any
+Section: devel
+Depends: libhildondesktop1
+Description: Qt 4 homescreen widget loader
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This package provides a loader for loading Qt homescreen widgets
+
+Package: qt4-maemo5-homescreen-loader-dbg
+Priority: extra
+Architecture: any
+Section: devel
+Depends: qt4-maemo5-homescreen-loader
+Description: Qt 4 library debugging symbols
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This packages contains the debugging symbols for the Qt 4 homescreen loader
+
+Package: qt4-maemo5-homescreen-example
+Architecture: any
+Section: devel
+Depends: libqt4-maemo5-core (>= 4.6.1), libqt4-maemo5-gui (>= 4.6.1), qt4-maemo5-homescreen-loader
+Description: Qt 4 Declarative development files
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This package contains an example homescreen widget done with Qt 4
diff --git a/debian/qt4-maemo5-homescreen-example.install b/debian/qt4-maemo5-homescreen-example.install
new file mode 100644
index 0000000..ce57662
--- /dev/null
+++ b/debian/qt4-maemo5-homescreen-example.install
@@ -0,0 +1,3 @@
+/usr/lib/hildon-desktop/qt-homescreen-example
+/usr/share/applications/hildon-home/qt-homescreen-example.desktop
+
diff --git a/debian/qt4-maemo5-homescreen-loader.install b/debian/qt4-maemo5-homescreen-loader.install
new file mode 100644
index 0000000..2cfcfde
--- /dev/null
+++ b/debian/qt4-maemo5-homescreen-loader.install
@@ -0,0 +1 @@
+/usr/lib/hildon-desktop/loaders/libqtpluginloader.so
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9389de5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+
+export DH_VERBOSE=1
+
+# Only present in official source package
+#QTVERSION := $(shell ls changes-* | cut -f2 -d '-')
+CURRENTVERSION := $(shell head -1 debian/changelog | sed 's/[^(]*(\([^)]*\)).*/\1/')
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+# Find out how many parallel threads to run
+comma := ,
+TMP_BUILD_OPTS = $(subst $(comma), ,$(DEB_BUILD_OPTIONS))
+ifneq (,$(filter parallel=%,$(TMP_BUILD_OPTS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(TMP_BUILD_OPTS)))
+ PARALLEL_MAKEFLAGS += -j$(NUMJOBS)
+endif
+
+DEB_MAKE_INVOKE := $(MAKE) $(PARALLEL_MAKEFLAGS)
+DEB_MAKE_BUILD_TARGET := all
+DEB_MAKE_INSTALL_TARGET := INSTALL_ROOT=$(DEB_DESTDIR) install
+DEB_DH_INSTALL_SOURCEDIR := debian/tmp
+DEB_DH_ALWAYS_EXCLUDE := .git
+
+# Ensure the *.debug files aren't included in any package other than libqt4-maemo5-dbg
+DEB_DH_INSTALL_ARGS := --exclude=.debug
+
+DEB_MAKE_CLEAN_TARGET := distclean
+
+# Shlibs of the current upstream version
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+
+DEB_DH_STRIP_ARGS := --dbg-package=qt4-maemo5-homescreen-loader
+DEB_DH_SHLIBDEPS_ARGS_ALL := --exclude=.debug
+
+# Only present in official source package
+#DEB_INSTALL_CHANGELOGS_ALL := changes-$(QTVERSION)
+
+common-configure-arch::
+ /opt/qt4-maemo5/bin/qmake CONFIG+=separate_debug_info CONFIG+=separate_debug_info_nocopy QMAKE_CXXFLAGS+="-g" QMAKE_CFLAGS+="-g"
+