summaryrefslogtreecommitdiffstats
path: root/RadioTuner/debian
diff options
context:
space:
mode:
Diffstat (limited to 'RadioTuner/debian')
-rwxr-xr-xRadioTuner/debian/changelog5
-rwxr-xr-xRadioTuner/debian/compat1
-rwxr-xr-xRadioTuner/debian/control12
-rw-r--r--RadioTuner/debian/copyright44
-rwxr-xr-xRadioTuner/debian/rules43
5 files changed, 105 insertions, 0 deletions
diff --git a/RadioTuner/debian/changelog b/RadioTuner/debian/changelog
new file mode 100755
index 0000000..630283b
--- /dev/null
+++ b/RadioTuner/debian/changelog
@@ -0,0 +1,5 @@
+radiotuner (1.0-maemo1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Anselmo Lacerda S. de Melo <anselmo.melo@openbossa.org> Fri, 16 Aug 2010 10:20:34 -0300
diff --git a/RadioTuner/debian/compat b/RadioTuner/debian/compat
new file mode 100755
index 0000000..7ed6ff8
--- /dev/null
+++ b/RadioTuner/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/RadioTuner/debian/control b/RadioTuner/debian/control
new file mode 100755
index 0000000..5af8b26
--- /dev/null
+++ b/RadioTuner/debian/control
@@ -0,0 +1,12 @@
+Source: radiotuner
+Section: user/apps
+Priority: optional
+Maintainer: Anselmo Lacerda S. de Melo <anselmo.melo@openbossa.org>
+Build-Depends: debhelper (>= 4)
+Standards-Version: 3.8.1
+
+Package: radiotuner
+Architecture: any
+Depends: libqt4-declarative
+Maemo-Display-Name: RadioTuner
+Description: radiotuner
diff --git a/RadioTuner/debian/copyright b/RadioTuner/debian/copyright
new file mode 100644
index 0000000..1205881
--- /dev/null
+++ b/RadioTuner/debian/copyright
@@ -0,0 +1,44 @@
+This package was debianized by Anselmo Melo <anselmo.melo@openbossa.org> on
+Tue, 24 Aug 2010 11:08:33 -0300.
+
+Upstream Author: Ian Andrade <ian.andrade@openbossa.org>
+
+Copyright: 2010 Nokia Corporation and/or its subsidiary(-ies).
+ All rights reserved.
+ Contact: Nokia Corporation (qt-info@nokia.com)
+
+License:
+ You may use this file under the terms of the BSD license as follows:
+
+ "Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ * Neither the name of Nokia Corporation and its Subsidiary(-ies) nor
+ the names of its contributors may be used to endorse or promote
+ products derived from this software without specific prior written
+ permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+ FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+ COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+ BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+ LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+ CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ POSSIBILITY OF SUCH DAMAGE."
+
+
+The Debian packaging is (C) 2010, Anselmo Melo <anselmo.melo@openbossa.org> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/RadioTuner/debian/rules b/RadioTuner/debian/rules
new file mode 100755
index 0000000..38067b9
--- /dev/null
+++ b/RadioTuner/debian/rules
@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+
+configure:
+ dh_testdir
+
+build: build-stamp
+ /usr/bin/qmake
+ make
+
+build-stamp: configure
+ dh_testdir
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ install -D -m 755 $(CURDIR)/build/radiotuner $(CURDIR)/debian/radiotuner/usr/bin/radiotuner
+ install -D -m 644 $(CURDIR)/radiotuner.desktop $(CURDIR)/debian/radiotuner/usr/share/applications/hildon/radiotuner.desktop
+ install -D -m 644 $(CURDIR)/icons/radiotuner.png $(CURDIR)/debian/radiotuner/usr/share/pixmaps/radiotuner.png
+
+binary-indep: build install
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure