summaryrefslogtreecommitdiffstats
path: root/mybudget/debian
diff options
context:
space:
mode:
Diffstat (limited to 'mybudget/debian')
-rw-r--r--mybudget/debian/changelog6
-rw-r--r--mybudget/debian/control11
-rw-r--r--mybudget/debian/qtmobiledemo-mybudget.install3
-rwxr-xr-xmybudget/debian/rules53
4 files changed, 58 insertions, 15 deletions
diff --git a/mybudget/debian/changelog b/mybudget/debian/changelog
index e5c7a60..b3862ed 100644
--- a/mybudget/debian/changelog
+++ b/mybudget/debian/changelog
@@ -1,3 +1,9 @@
+qtmobiledemo-mybudget (0.4-maemo1) unstable; urgency=low
+
+ * Updated for Maemo PR 1.2
+
+ -- Anselmo Lacerda S. de Melo <anselmo.melo@openbossa.org> Mon, 29 May 2010 18:00:43 -0300
+
qtmobiledemo-mybudget (0.3-maemo1) unstable; urgency=low
* First package for Maemo5 repositories.
diff --git a/mybudget/debian/control b/mybudget/debian/control
index 658d3cd..ac70f24 100644
--- a/mybudget/debian/control
+++ b/mybudget/debian/control
@@ -1,14 +1,15 @@
Source: qtmobiledemo-mybudget
-Section: apps
-Priority: optional
+Section: user/Other
+Priority: extra
Maintainer: Jesus Sanchez-Palencia <jesus.palencia@openbossa.org>
-Build-Depends: debhelper (>= 4), libqt4-maemo5-dev
+Build-Depends: debhelper (>= 5), libqt4-dev
Standards-Version: 3.8.1
+Homepage: http://qt.gitorious.org/qt-labs/mobile-demos
Package: qtmobiledemo-mybudget
-Section: user/other
+Section: user/Other
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libqt4-maemo5-core, libqt4-maemo5-gui
+Depends: ${shlibs:Depends}, ${misc:Depends}
XB-Maemo-Display-Name: Qt Mobile Demo: MyBudget
XB-Maemo-Icon-26:
iVBORw0KGgoAAAANSUhEUgAAADAAAAAwCAMAAABg3Am1AAAAAXNSR0IArs4c
diff --git a/mybudget/debian/qtmobiledemo-mybudget.install b/mybudget/debian/qtmobiledemo-mybudget.install
deleted file mode 100644
index 0a5e883..0000000
--- a/mybudget/debian/qtmobiledemo-mybudget.install
+++ /dev/null
@@ -1,3 +0,0 @@
-maemo/mybudget.desktop usr/share/applications/hildon/
-mybudget-icon.png usr/share/pixmaps/
-maemo/start_mybudget.sh usr/bin/
diff --git a/mybudget/debian/rules b/mybudget/debian/rules
index 7af054f..cb495ff 100755
--- a/mybudget/debian/rules
+++ b/mybudget/debian/rules
@@ -1,11 +1,50 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/qmake.mk
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ qmake -r PREFIX=/usr
+ touch configure-stamp
-QMAKE = /opt/qt4-maemo5/bin/qmake
-DEB_BUILDDIR = debian/builddeb
-DEB_QMAKE_ARGS = $(CURDIR)/mybudget.pro -r PREFIX=/usr
+build: build-stamp
-clean::
- rm -fr $(DEB_BUILDDIR)
+build-stamp: configure-stamp
+ dh_testdir
+
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ -$(MAKE) distclean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/qtmobiledemo-mybudget install
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure