summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKim Gronholm <kim.1.gronholm@nokia.com>2011-05-03 13:30:58 +0300
committerKim Gronholm <kim.1.gronholm@nokia.com>2011-05-03 13:30:58 +0300
commit7aac6c99df60af961fb0acf14d6f050695756174 (patch)
treef7c30d2dc048cc7dcd3610561cf88cc6f6e5dc0f /debian
Initial commit
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/compat1
-rwxr-xr-xdebian/configure_package_install_files33
-rw-r--r--debian/control39
-rw-r--r--debian/qmlshadersplugin-demos.install6
-rw-r--r--debian/qmlshadersplugin.install2
-rwxr-xr-xdebian/rules94
7 files changed, 186 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..f78427d
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+qmlshadersplugin (1.0~git20110414~1) UNRELEASED; urgency=low
+
+ * Debian packaging for the whole project
+
+ -- Aleksandar Stojiljkovic <aleksandar.stojiljkovic@nokia.com> Thu, 14 Apr 2011 12:40:07 +0300
+
+qmlshadersplugin (1.0~git20110121-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Kim Grönholm <kim.1.gronholm@nokia.com> Fri, 21 Jan 2011 15:21:07 +0300
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/configure_package_install_files b/debian/configure_package_install_files
new file mode 100755
index 0000000..68968e2
--- /dev/null
+++ b/debian/configure_package_install_files
@@ -0,0 +1,33 @@
+#!/bin/sh
+# =================================================================================================
+# Replace QT_INSTALL_IMPORTS pattern in package.install files with
+# path to Qt imports installation.
+# =================================================================================================
+
+# =================================================================================================
+# Get where is Qt imports installation folder
+# =================================================================================================
+
+export QT_INSTALL_IMPORTS_PATH=$(qmake -query QT_INSTALL_IMPORTS)
+if [ -z $QT_INSTALL_IMPORTS_PATH ]; then
+ echo "configure error: qmake -query QT_INSTALL_IMPORTS returned empty string."
+ export QT_INSTALL_IMPORTS_PATH=usr/lib/qt4/imports
+fi
+
+# =================================================================================================
+# Process package.install.in files to generate package.install.
+# Not that package.install.in files contain QT_INSTALL_IMPORTS string that with following block
+# replaces pattern with Qt imports installation path, for all debian/package.install.in files
+# creates debian/package.install with replaced content.
+# =================================================================================================
+
+IN_EXT=install.in
+OUT_EXT=install
+
+cd $(pwd)/debian
+
+for i in $(ls *.$IN_EXT)
+do
+ sed "s#QT_INSTALL_IMPORTS#$QT_INSTALL_IMPORTS_PATH#g" $i > ${i%.$IN_EXT}.$OUT_EXT
+done
+
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0ce44b4
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,39 @@
+Source: qmlshadersplugin
+Section: libs
+Priority: optional
+Maintainer: Kim Grönholm <kim.1.gronholm@nokia.com>
+Build-Depends: debhelper (>= 5), libqt4-dev(>= 4.7.0~), libqt4-declarative(>= 4.7.0~), libqt4-opengl-dev
+Standards-Version: 3.7.2
+
+Package: qmlshadersplugin
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: QML Shader Effects plugin
+ QML Shader Effects plugin
+
+Package: qmlshadersplugin-dbg
+Section: debug
+Architecture: any
+Depends: qmlshadersplugin (=${binary:Version})
+Description: QML Shader Effects plugin (debug symbols)
+ QML Shader Effects plugin
+ .
+ This package contains debugging symbols for qmlshadersplugin.
+
+Package: qmlshadersplugin-demos
+Section: apps
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, qmlshadersplugin
+Description: Example projects demonstrating shader effects in QML
+ Example projects demonstrating shader effects in QML
+
+Package: qmlshadersplugin-demos-dbg
+Priority: extra
+Architecture: any
+Section: debug
+Depends: ${shlibs:Depends}, ${misc:Depends}, effectsuite
+Description: Example projects demonstrating shader effects in QML (debug symbols)
+ Example projects demonstrating shader effects in QML
+ .
+ This package contains the debugging symbols for QML shader effects demo applications,
+
diff --git a/debian/qmlshadersplugin-demos.install b/debian/qmlshadersplugin-demos.install
new file mode 100644
index 0000000..611bf4f
--- /dev/null
+++ b/debian/qmlshadersplugin-demos.install
@@ -0,0 +1,6 @@
+usr/share/shadereffects/qml/*
+usr/share/helloworld/qml/*
+usr/share/applications/*
+usr/share/icons/hicolor/64x64/apps/*
+usr/bin/helloworld
+usr/bin/shadereffects
diff --git a/debian/qmlshadersplugin.install b/debian/qmlshadersplugin.install
new file mode 100644
index 0000000..1e0fd6f
--- /dev/null
+++ b/debian/qmlshadersplugin.install
@@ -0,0 +1,2 @@
+/usr/lib/qt4/imports/Qt/labs/shaders/libqmlshadersplugin.so
+/usr/lib/qt4/imports/Qt/labs/shaders/qmldir
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ee1eef2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,94 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+TMP_BUILD_OPTS = $(subst $(comma),$(space),$(DEB_BUILD_OPTIONS))
+MAKEDEMOS = 1
+
+ifneq (,$(filter parallel=%,$(TMP_BUILD_OPTS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(TMP_BUILD_OPTS)))
+ PARALLEL_MAKEFLAGS += -j$(NUMJOBS)
+endif
+
+# Disable building of demos by setting DEB_BUILD_OPTION=nodemos,...
+ifneq (,$(filter nodemos,$(TMP_BUILD_OPTS)))
+ #No demos
+ EXCLUSIONS += --no-package=qmlshadersplugin-demos
+ EXCLUSIONS += --no-package=qmlshadersplugin-demos-dbg
+ MAKEDEMOS = 0
+endif
+
+QMAKE_OPTIONS += CONFIG+=release
+# Add debug symbols to release configuration, and prevent make to strip them
+# (these are later stripped from binaries into dbg package with dh_strip).
+QMAKE_OPTIONS += QMAKE_CXXFLAGS_RELEASE+=-g
+QMAKE_OPTIONS += QMAKE_STRIP=echo
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ qmake -r $(QMAKE_OPTIONS)
+ +$(MAKE) $(PARALLEL_MAKEFLAGS)
+ifneq (0,$(MAKEDEMOS))
+ qmake -r $(QMAKE_OPTIONS) ./demos.pro -o Makefile_demos
+ +$(MAKE) $(PARALLEL_MAKEFLAGS) -f Makefile_demos
+endif
+ touch $@
+
+install: install-stamp
+
+install-stamp: build-stamp
+ dh_testdir
+ dh_testroot
+
+# FIXME check if dh_prep is available for maemo5 - N900 to replace deprecated dh_clean -k
+ dh_clean -k
+
+ dh_installdirs
+ INSTALL_ROOT=$(CURDIR)/debian/tmp $(MAKE) install
+ifneq (0,$(MAKEDEMOS))
+ INSTALL_ROOT=$(CURDIR)/debian/tmp $(MAKE) -f Makefile_demos install
+endif
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ $(MAKE) distclean -f Makefile || true
+ $(MAKE) distclean -f Makefile_demos || true
+
+ dh_clean build-stamp install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir $(EXCLUSIONS)
+ +./debian/configure_package_install_files
+ dh_testroot $(EXCLUSIONS)
+ dh_installchangelogs $(EXCLUSIONS)
+ dh_installdocs $(EXCLUSIONS)
+ dh_install --sourcedir=debian/tmp/ $(EXCLUSIONS) -v
+ # print warnings for not installed files
+ dh_install --sourcedir=debian/tmp/ $(EXCLUSIONS) --list-missing
+ dh_link $(EXCLUSIONS)
+ dh_strip -p qmlshadersplugin --dbg-package=qmlshadersplugin-dbg
+ifneq (0,$(MAKEDEMOS))
+ dh_strip -p qmlshadersplugin-demos --dbg-package=qmlshadersplugin-demos-dbg
+endif
+ dh_compress $(EXCLUSIONS)
+ dh_fixperms $(EXCLUSIONS)
+ dh_makeshlibs $(EXCLUSIONS)
+ dh_installdeb $(EXCLUSIONS)
+ dh_shlibdeps $(EXCLUSIONS)
+ dh_gencontrol $(EXCLUSIONS)
+ dh_md5sums $(EXCLUSIONS)
+ dh_builddeb $(EXCLUSIONS)
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
+