summaryrefslogtreecommitdiffstats
path: root/app-mobilephone/runonphone/runonphone-4.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/runonphone/runonphone-4.7.1.ebuild')
-rw-r--r--app-mobilephone/runonphone/runonphone-4.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-mobilephone/runonphone/runonphone-4.7.1.ebuild b/app-mobilephone/runonphone/runonphone-4.7.1.ebuild
new file mode 100644
index 0000000..99dc0e1
--- /dev/null
+++ b/app-mobilephone/runonphone/runonphone-4.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Copyright 2010 Nokia Corporation and/or its subsidiary(-ies)
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Tool to automatically install and run applications on Symbian phones"
+HOMEPAGE="http://qt.nokia.com/"
+
+MY_PV=${PV/_/-}
+SRC_URI="http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${MY_PV}.tar.gz"
+LICENSE="LGPL-2.1 GPL-3"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=x11-libs/qt-core-4.6.0"
+
+src_compile() {
+ cd qt-everywhere-opensource-src-${MY_PV}/tools/runonphone
+ qmake || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd qt-everywhere-opensource-src-${MY_PV}/tools/runonphone
+ exeinto /usr/bin
+ doexe runonphone || die "install failed"
+}