summaryrefslogtreecommitdiffstats
path: root/runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/CMakeLists.txt')
-rw-r--r--runtime/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/runtime/CMakeLists.txt b/runtime/CMakeLists.txt
index 6f453f96d7..e1e52b0e45 100644
--- a/runtime/CMakeLists.txt
+++ b/runtime/CMakeLists.txt
@@ -18,7 +18,7 @@ function(get_ext_project_build_command out_var target)
set(${out_var} "$(MAKE)" "${target}" PARENT_SCOPE)
else()
set(${out_var} ${CMAKE_COMMAND} --build . --target ${target}
- --config $<CONFIGURATION> PARENT_SCOPE)
+ --config $<CONFIG> PARENT_SCOPE)
endif()
endfunction()
@@ -58,12 +58,16 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
endif()
endforeach()
+ set(compiler_rt_configure_deps)
if(TARGET cxx-headers)
- set(COMPILER_RT_LIBCXX_DEPENDENCY "cxx-headers")
+ list(APPEND compiler_rt_configure_deps "cxx-headers")
+ endif()
+ if(LLVM_INCLUDE_TESTS)
+ list(APPEND compiler_rt_configure_deps LLVMTestingSupport)
endif()
ExternalProject_Add(compiler-rt
- DEPENDS llvm-config clang ${COMPILER_RT_LIBCXX_DEPENDENCY}
+ DEPENDS llvm-config clang ${compiler_rt_configure_deps}
PREFIX ${COMPILER_RT_PREFIX}
SOURCE_DIR ${COMPILER_RT_SRC_ROOT}
STAMP_DIR ${STAMP_DIR}