summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerry Boland <gerry.boland@canonical.com>2015-07-13 19:51:25 +0100
committerGerry Boland <gerry.boland@canonical.com>2015-07-13 19:51:25 +0100
commit76fdf7180bff9add177b6a91334171428b3806f4 (patch)
tree72f115990f26d47f980c4e135d18a683252b4432 /CMakeLists.txt
parentec03118336af538ce0af198adb9cdc571150ae16 (diff)
We depend on Qt 5.4, remove compatibility code for older versions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 665acfe..c3f9188 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,13 +50,13 @@ add_custom_target(cppcheck COMMAND cppcheck --enable=all -q --error-exitcode=2
${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests)
include(FindPkgConfig)
-find_package(Qt5Core 5.3 REQUIRED)
-find_package(Qt5DBus 5.3 REQUIRED)
-find_package(Qt5Gui 5.3 REQUIRED)
-find_package(Qt5Qml 5.3 REQUIRED)
-find_package(Qt5Quick 5.3 REQUIRED)
-find_package(Qt5Sensors 5.3 REQUIRED)
-find_package(Qt5Test 5.3 REQUIRED)
+find_package(Qt5Core 5.4 REQUIRED)
+find_package(Qt5DBus 5.4 REQUIRED)
+find_package(Qt5Gui 5.4 REQUIRED)
+find_package(Qt5Qml 5.4 REQUIRED)
+find_package(Qt5Quick 5.4 REQUIRED)
+find_package(Qt5Sensors 5.4 REQUIRED)
+find_package(Qt5Test 5.4 REQUIRED)
find_package(Threads REQUIRED)