summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Carr <robert.carr@canonical.com>2014-09-22 11:02:42 -0700
committerRobert Carr <robert.carr@canonical.com>2014-09-22 11:02:42 -0700
commitb9a4d4d237c85ac5b8117a16c31a584025f59b11 (patch)
tree5213047f99e167de83a0136e041a6b347fc6ebd5 /CMakeLists.txt
parent769bd9b041efa681af88d7129d7aa346ac6ff337 (diff)
Cleanup main CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5de4bfd..45630a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,16 +76,7 @@ pkg_check_modules(GIO gio-2.0)
pkg_check_modules(LTTNG lttng-ust)
-# detect if Qt compiled with GL or GLES
-#include(CheckCXXSourceCompiles)
-#check_cxx_source_compiles("
-#include <QtCore/QtGlobal>
-#if !defined(QT_OPENGL_ES)
-#error \"No OpenGLES\"
-#endif
-#int main() {}
-#" USE_OPENGLES)
-
+# We expect this to be set via debian/rules for GLES builds
if ("${USE_OPENGLES}" STREQUAL 1)
message(STATUS "Qt5 determined to be compiled with GLES support")
find_package(GLESv2 REQUIRED)
@@ -147,7 +138,7 @@ endif()
# Mir uses boost, which does not like Qt defining macros named "signals" and "slots"
-#add_definitions(-DQT_NO_KEYWORDS)
+add_definitions(-DQT_NO_KEYWORDS)
# Tests
include(CTest)