summaryrefslogtreecommitdiffstats
path: root/src/modules/Unity/Application/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/Unity/Application/CMakeLists.txt')
-rw-r--r--src/modules/Unity/Application/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/modules/Unity/Application/CMakeLists.txt b/src/modules/Unity/Application/CMakeLists.txt
index 62dc79d..2128e4b 100644
--- a/src/modules/Unity/Application/CMakeLists.txt
+++ b/src/modules/Unity/Application/CMakeLists.txt
@@ -1,4 +1,5 @@
include_directories(
+ ${APPLICATION_API_INCLUDE_DIRS}
${GLIB_INCLUDE_DIRS}
${GIO_INCLUDE_DIRS}
${GIO_UNIX_INCLUDE_DIRS}
@@ -9,6 +10,7 @@ include_directories(
${UBUNTU_APP_LAUNCH_INCLUDE_DIRS}
${CMAKE_SOURCE_DIR}/src/platforms/mirserver
${CMAKE_SOURCE_DIR}/src/common
+ ${GSETTINGS_QT_INCLUDE_DIRS}
${LTTNG_INCLUDE_DIRS}
${Qt5Gui_PRIVATE_INCLUDE_DIRS}
@@ -41,12 +43,14 @@ set(QMLMIRPLUGIN_SRC
sharedwakelock.cpp
upstart/applicationcontroller.cpp
tracepoints.c
+ settings.cpp
# We need to run moc on these headers
- /usr/include/unity/shell/application/ApplicationInfoInterface.h
- /usr/include/unity/shell/application/ApplicationManagerInterface.h
+ ${APPLICATION_API_INCLUDEDIR}/unity/shell/application/ApplicationInfoInterface.h
+ ${APPLICATION_API_INCLUDEDIR}/unity/shell/application/ApplicationManagerInterface.h
# Feed the automoc monster
session_interface.h
applicationcontroller.h
+ settings_interface.h
)
add_library(unityapplicationplugin SHARED
@@ -64,6 +68,7 @@ target_link_libraries(
${PROCESS_CPP_LDFLAGS}
${UBUNTU_APP_LAUNCH_LDFLAGS}
${LTTNG_LDFLAGS}
+ ${GSETTINGS_QT_LDFLAGS}
${GL_LIBRARIES}
@@ -82,3 +87,5 @@ add_lttng_gen_tp(NAME tracepoints)
# install
add_qml_plugin(Unity.Application 0.1 Unity/Application TARGETS unityapplicationplugin)
+install(FILES com.canonical.qtmir.gschema.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/glib-2.0/schemas)
+