summaryrefslogtreecommitdiffstats
path: root/tests/modules/General/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/General/CMakeLists.txt')
-rw-r--r--tests/modules/General/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/modules/General/CMakeLists.txt b/tests/modules/General/CMakeLists.txt
new file mode 100644
index 0000000..a9aa3b3
--- /dev/null
+++ b/tests/modules/General/CMakeLists.txt
@@ -0,0 +1,30 @@
+set(
+ GENERAL_TEST_SOURCES
+ objectlistmodel_test.cpp
+ ${CMAKE_SOURCE_DIR}/src/common/debughelpers.cpp
+)
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/src/platforms/mirserver
+ ${CMAKE_SOURCE_DIR}/src/common
+ ${CMAKE_SOURCE_DIR}/src/modules
+ ${CMAKE_SOURCE_DIR}/tests/modules/common
+ ${Qt5Gui_PRIVATE_INCLUDE_DIRS}
+ ${MIRSERVER_INCLUDE_DIRS}
+)
+
+add_executable(general_test ${GENERAL_TEST_SOURCES})
+
+target_link_libraries(
+ general_test
+
+ qpa-mirserver
+ unityapplicationplugin
+
+ Qt5::Gui
+
+ ${GTEST_BOTH_LIBRARIES}
+ ${GMOCK_LIBRARIES}
+)
+
+add_test(General general_test)