summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-06-06 15:47:19 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-06-06 15:05:01 +0000
commitdeeb47d8bf051d124ea6e54b4c91645bc64435a9 (patch)
tree3e415bb936b8c0908e01817783c429c0c677c0c0
parente58320653e3e455685636b58750088f806b98533 (diff)
Current limited API packages won't work on Python 3.7 and 3.8
This is intentional, because of verification code regarding Python buffers. So instead of lying, we remove those python version bits from the generated package name, aka instead of "cp35.cp36.cp37.cp38" it is now only "cp35.cp36". Change-Id: I2891f64e93821d3a3ccb693f28576c34d1365606 Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io> Reviewed-by: Christian Tismer <tismer@stackless.com>
-rw-r--r--build_scripts/wheel_override.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/build_scripts/wheel_override.py b/build_scripts/wheel_override.py
index ee8bd838..f6eaedf1 100644
--- a/build_scripts/wheel_override.py
+++ b/build_scripts/wheel_override.py
@@ -195,6 +195,6 @@ if wheel_module_exists:
# create a properly named package.
limited_api_enabled = OPTION_LIMITED_API and sys.version_info[0] >= 3
if limited_api_enabled:
- self.py_limited_api = "cp35.cp36.cp37.cp38"
+ self.py_limited_api = "cp35.cp36"
_bdist_wheel.finalize_options(self)