aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYaakov <yselkowitz@users.sourceforge.net>2011-10-27 14:53:31 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:18:24 -0300
commitebbc17b83cedcd5e41a402bef8ab294c2e9b0152 (patch)
tree83de99c09437b34ef6ed4cd71c87dd44533258dc /CMakeLists.txt
parent18dca4b184bff9978992f728ead0c25658d95071 (diff)
Fix bug 1010 - "Shiboken Cygwin patch."
Reviewer: Hugo Parente Lima <hugo.lima@openbossa.org> Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 264334962..15e79d4ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,7 @@ endif()
if(MSVC)
set(CMAKE_CXX_FLAGS "/Zc:wchar_t- /GR /EHsc /DWIN32 /D_WINDOWS /D_SCL_SECURE_NO_WARNINGS")
else()
- if(CMAKE_HOST_UNIX)
+ if(CMAKE_HOST_UNIX AND NOT CYGWIN)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fvisibility=hidden -Wno-strict-aliasing")
endif()
set(CMAKE_CXX_FLAGS_DEBUG "-g")