aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-03-02 18:52:33 -0300
committerHugo Lima <hugo.lima@openbossa.org>2010-03-04 17:17:31 -0300
commit6f19bc36d75249c32a0b30e55460ed3e0348bc23 (patch)
treee8520b76be7ee0ab0077443b9fb290617b7f0bc0 /CMakeLists.txt
parent77bb1220b4bc7d538d1e57cf6011d7b3fbe42925 (diff)
Fix compilation of QtCore when using -DAVOID_PROTECTED_HACK.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42f308f64..d7bfd8b23 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,12 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release)
endif()
+option(AVOID_PROTECTED_HACK "Avoid protected hack on generated bindings." FALSE)
+if (AVOID_PROTECTED_HACK OR WIN32)
+ add_definitions(-DAVOID_PROTECTED_HACK)
+ message(STATUS "Avoiding protected hack!")
+endif()
+
find_package(PythonLibs REQUIRED)
find_package(PythonInterp REQUIRED)
find_package(Shiboken REQUIRED)