aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-07-20 15:30:31 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-07-21 17:14:34 -0300
commit2194250dbb9d8863d70b90e167b4d3527ff832ed (patch)
tree7a22ff7607040da9961e2a0c300bd478c4b7f823 /CMakeLists.txt
parent10828a918d387d34cafb8709cea18f02d1af7af2 (diff)
Added a custom cmake file to help finding Python debug provisions.
Reviewed by Luciano Wolf <luciano.wolf@openbossa.org> Reviewed by Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aeeaef090..21cd2de1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,11 +3,14 @@ project(shiboken)
cmake_minimum_required(VERSION 2.6)
+set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules/
+ ${CMAKE_MODULE_PATH})
+
find_package(Qt4 4.5.0 REQUIRED)
find_package(ApiExtractor 0.7 REQUIRED)
find_package(GeneratorRunner 0.6 REQUIRED)
find_package(PythonLibs REQUIRED)
-find_package(PythonInterp REQUIRED)
+find_package(PythonInterpWithDebug REQUIRED)
add_definitions(${QT_DEFINITIONS})