aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-11-19 20:32:17 -0200
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-11-20 10:46:50 -0300
commit5314e3eb7159a456fae38a59e586ad09e8cf0238 (patch)
treeaaf94964c72625150282298573e1225aac21e7c0 /CMakeLists.txt
parentf1962c58cbb914681e19c843918c29811d0e61c9 (diff)
Set default symbol visibility to hidden, so pyside is even smaller!
1.4MB on my 64bits machine. Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99e19315d..40f06f382 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,8 @@ include(icecc.cmake) # this must be the first line!
cmake_minimum_required(VERSION 2.6)
-set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -Os -Wl,-O1 -Wl,--hash-style=gnu -Wno-strict-aliasing")
-set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-common -Wall -fno-strict-aliasing")
+set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -Os -Wl,-O1 -Wl,--hash-style=gnu -Wno-strict-aliasing -fvisibility=hidden")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -fno-common -Wall -fno-strict-aliasing -fvisibility=hidden")
find_package(PythonLibs REQUIRED)
find_package(PythonInterp REQUIRED)