aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-12-22 18:50:54 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:12:50 -0300
commit5b57a4085dc68640870373b00f3d7c8dd894a466 (patch)
treec361975a70a3e49bf3b743e4aac32c6b8ad75889 /CMakeLists.txt
parent39b90917d70c542e27615f915bb73e9ae8c98df8 (diff)
Minor changed in CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80eb5d384..cfacdb844 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,10 +92,6 @@ if(APPLE)
set(SBK_PYTHON_LIBRARIES "-undefined dynamic_lookup")
endif()
-if (BUILD_TESTS)
- enable_testing()
-endif()
-
add_subdirectory(libshiboken)
add_subdirectory(doc)
@@ -104,10 +100,11 @@ if (QT4_FOUND AND ApiExtractor_FOUND AND GeneratorRunner_FOUND AND PYTHONLIBS_FO
add_subdirectory(generator)
if (BUILD_TESTS)
+ enable_testing()
add_subdirectory(tests)
endif()
else()
- message("!! Some dependencies were not found, shiboken generator compilation disabled!")
+ message(WARNING "Some dependencies were not found, shiboken generator compilation disabled!")
endif()
if(CMAKE_VERSION VERSION_LESS 2.8)
@@ -115,8 +112,10 @@ if(CMAKE_VERSION VERSION_LESS 2.8)
else()
set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_DIRS})
endif()
+
add_subdirectory(data)
+# dist target
set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${shiboken_VERSION})
add_custom_target(dist
COMMAND mkdir -p "${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}" &&