aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-08-28 14:44:10 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-08-28 14:44:10 -0300
commit4d97a7317791a274e95e09e5a073f475362fbc37 (patch)
tree68c1338055b687a29072fa2de2ffa878c606a1f0 /CMakeLists.txt
parent0daf40446416f26fa4de8ae7734b1677a0b7f6d0 (diff)
Turned on compiler warnings by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28470eb94..92d52b724 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,9 @@ find_package(ApiExtractor REQUIRED)
add_definitions(${QT_DEFINITIONS})
+set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -O2 -Wl,-O1 -Wl,--hash-style=gnu")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall")
+
set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)