aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Woehlke <matthew.woehlke@kitware.com>2013-08-13 16:09:22 -0400
committerJohn Ehresman <jpe@wingware.com>2013-08-14 03:52:24 +0200
commiteb04a968b60da4e799ca89f2936a75ff63d915b1 (patch)
tree18f266b5994807830b1215ce1d15789e87c13937 /CMakeLists.txt
parent1f8db21ef969d16702eb962d2311ee3e50f39ce1 (diff)
Remove unnecessary line feed
Remove explicit '\n' from echo command in 'dist' target. This isn't needed (echo should output one regardless, so it only creates an additional empty line), and it is being parsed by CMake, which results in generating a build.ninja on at least Windows that cannot be parsed due to an unterminated string. Change-Id: I5d8aba12c71f5a9c29a07108c50499081ba7203a Reviewed-by: John Ehresman <jpe@wingware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c29cf90d..00b352a92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,7 +137,7 @@ add_custom_target(dist
git archive --prefix=${ARCHIVE_NAME}/ HEAD --format=tar --output="${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar" &&
tar -C "${CMAKE_BINARY_DIR}" --owner=root --group=root -r "${ARCHIVE_NAME}/ChangeLog" -f "${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar" &&
bzip2 -f9 "${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar" &&
- echo "Source package created at ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.bz2.\n"
+ echo "Source package created at ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.bz2."
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})