aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno dos Santos de Araujo <bruno.araujo@openbossa.org>2009-09-25 09:51:29 -0400
committerBruno dos Santos de Araujo <bruno.araujo@openbossa.org>2009-09-25 10:12:21 -0400
commit42562fa1c3794ba9657cdfd29cbee33000316d52 (patch)
tree466aeabbad0ae4bbba2e3280f32513908917fbeb /CMakeLists.txt
parent50bfbf524e84fee2b3e7cb7a6e74eab73cc99ab1 (diff)
Add manpages for generatorrunner, docgenerator and boostpythongenerator. (Fixes: #29)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdf3c5850..43ad61dd8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,10 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/generatorrunner.pc DESTINATION
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/FindGeneratorRunner.cmake
DESTINATION share/cmake-2.6/Modules)
+#FIXME: manpages should be installed only on Linux targets
+file(GLOB manpages ${CMAKE_CURRENT_SOURCE_DIR}/*.1)
+install(FILES ${manpages} DESTINATION share/man/man1)
+
enable_testing()
add_subdirectory(generators)