aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@openbossa.org>2011-01-11 17:58:52 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:51:45 -0300
commit7e667036d58a0549dd08a152149e1ba1f410bfb7 (patch)
tree769fa7c55ba73d1426b9eb76ba93d32f4e5fb508 /CMakeLists.txt
parent99cbdef40cda9379651951d0f187fbba6e829ae1 (diff)
Use python base name as library prefix.
Use the same CMAKE_BUILD_TYPE as shiboken if none was specified. Append SHIBOKEN_PYTHON_BASENAME in the library suffix. Fix bug #509. Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Lauro Moura <lauro.neto@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33eda537c..856ed6a9f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,7 +56,7 @@ else()
endif()
if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE Release)
+ set(CMAKE_BUILD_TYPE ${SHIBOKEN_BUILD_TYPE})
endif()
set(BINDING_NAME PySide)