aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2010-01-25 12:02:38 -0300
committerLauro Neto <lauro.neto@openbossa.org>2010-01-25 13:47:59 -0300
commit0c0c256c244ce171151a0dac2e444912bb1f9692 (patch)
treed2f30015759aba407dc7b5d6ebd672c94df2a423 /CMakeLists.txt
parenta01d5c8d9e056a06a3aa4a16bc608b125da105ac (diff)
Setting CMAKE_BUILD_TYPE before usage
Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dea739657..870f8adf4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,11 @@ add_definitions(${QT_DEFINITIONS})
option(AVOID_PROTECTED_HACK "Avoid protected hack on generated bindings." FALSE)
+if (NOT CMAKE_BUILD_TYPE)
+ message("No build type provided. Setting to Debug by default")
+ set(CMAKE_BUILD_TYPE "Debug")
+endif()
+
if (MSVC)
set(CMAKE_CXX_FLAGS "/DWIN32 /D_WINDOWS /w /EHsc- /GS- /GR- /DLIBSHIBOKEN_BUILD -D_SCL_SECURE_NO_WARNINGS")
else()
@@ -32,7 +37,6 @@ set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)
set(shiboken_VERSION 0.1)
-set(CMAKE_BUILD_TYPE Debug)
set(shiboken_SRC
cppgenerator.cpp